View Issue Details

IDProjectCategoryView StatusLast Update
0004603unrealircdpublic2016-04-04 11:12
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version4.0.2 
Target VersionFixed in Version4.0.3 
Summary0004603: Crash reports with gdb missing (improvement)
DescriptionAbout 80% of the crash reports don't have a backtrace because gdb is not installed on the system. We'd need to handle this another way, as often no contact information is provided making the entire bug report completely useless.

Suggestions would be auto-tar.gz'ing and asking to email, or even doing something automatic (after prompting). In any case, giving the users a heads up rather than the current situation.
Right now the user may be thinking they are doing a good job by submitting a crash report, while in fact no backtrace and no contact information is received.

Still glad with the other ~20% ;)
TagsNo tags attached.
3rd party modules

Activities

syzop

2016-03-24 08:15

administrator   ~0019145

look into tar.gz + upload, but only after user approval (check first how much MB this is on average and if our system can take it)

syzop

2016-04-04 11:12

administrator   ~0019194

[unreal40 9f4496b] Let crash reporter upload core files and binaries on *NIX. Should help a lot since many people don't have gdb installed, which caused us to receive reports with just 'gdb: command missing' as a stack trace. (0004603)

https://github.com/unrealircd/unrealircd/commit/9f4496b6a654b322b3aa2a9137fd6b6196b2ff53

Not the finest code, but it works well. This should really help us a lot.

Issue History

Date Modified Username Field Change
2016-03-24 08:12 syzop New Issue
2016-03-24 08:12 syzop Assigned To => syzop
2016-03-24 08:12 syzop Status new => assigned
2016-03-24 08:15 syzop Note Added: 0019145
2016-04-04 11:12 syzop Note Added: 0019194
2016-04-04 11:12 syzop Status assigned => resolved
2016-04-04 11:12 syzop Fixed in Version => 4.0.3
2016-04-04 11:12 syzop Resolution open => fixed