View Issue Details

IDProjectCategoryView StatusLast Update
0004666unrealinstallingpublic2016-04-24 10:52
Reporterstatic-xAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSFreebsdOS Version8.4 & 9.3
Product Version4.0.3 
Target VersionFixed in Version4.0.3.1 
Summary0004666: Unable to run make
DescriptionWhen I run make after Config Finishes I receieve the following error.

[syclone@athlon (~/unrealircd-4.0.3)]$ make
Building src
gcc -I/home/syclone/unrealircd-4.0.3/include -D_THREAD_SAFE -pthread -I/home/syclone/unrealircd-4.0.3/extras/regexp/include -I/home/syclone/unrealircd-4.0.3/extras/pcre2/include -I/home/syclone/unrealircd-4.0.3/extras/c-ares/include -pipe -g -O2 -funsigned-char -fno-strict-aliasing -Wno-pointer-sign -I/usr/local/include -Wl,-export-dynamic -L/usr/local/lib -lssl -lcrypto -o ircd timesynch.o res.o s_bsd.o auth.o aln.o channel.o cloak.o crule.o dbuf.o events.o fdlist.o hash.o ircd.o ircsprintf.o list.o match.o modules.o packet.o parse.o s_auth.o mempool.o operclass.o s_conf.o s_debug.o s_dispatch.o s_err.o s_extra.o s_kline.o s_misc.o s_numeric.o s_serv.o s_svs.o socket.o ssl.o s_user.o charsys.o scache.o send.o support.o umodes.o version.o whowas.o random.o extcmodes.o moddata.o uid.o extbans.o api-isupport.o api-command.o api-clicap.o md5.o crypt_blowfish.o updconf.o crashreport.o -lcrypt /home/syclone/unrealircd-4.0.3/extras/regexp/lib/libtre.a -L/home/syclone/unrealircd-4.0.3/extras/pcre2/lib -lpcre2-8 -D_THREAD_SAFE -pthread -L../extras/c-ares/lib -L/home/syclone/unrealircd-4.0.3/extras/c-ares/lib -lcares -lssl -lcrypto
crashreport.o: In function `crash_report_backtrace':
/home/syclone/unrealircd-4.0.3/src/crashreport.c:240: undefined reference to `WEXITSTATUS'
*** [ircd] Error code 1

Stop in /usr/home/syclone/unrealircd-4.0.3/src.
*** [build] Error code 1

Stop in /usr/home/syclone/unrealircd-4.0.3.
Steps To ReproduceDownload the Source
tar -zxvf unrealircd-latest.tar.gz
 cd unrealircd-4.0.3
./Config
make then i get error nothing shows up in the unrealircd folder but . .. tmp
Additional InformationTry this on version of freebsd
FreeBSD 8.4-RELEASE-pX
FreeBSD 9.3-STABLE #0 r285351
TagsNo tags attached.
3rd party modules

Relationships

related to 0004663 resolvedsyzop Compile problem on OpenBSD (missing include in crashreport.c) 

Activities

static-x

2016-04-24 02:21

reporter   ~0019215

After looking through the issues I found sysop already fixed this with the ticket 0004663. I modify those files with his changes and I was able to run make.

syzop

2016-04-24 10:26

administrator   ~0019216

Thanks! I'll do a 4.0.3.1 release since it affects both FreeBSD and OpenBSD.

syzop

2016-04-24 10:51

administrator   ~0019217

Done. Thanks for the report!

Release: https://forums.unrealircd.org/viewtopic.php?f=1&t=8526

In case you wonder: I don't have a FreeBSD test system myself. I waited two weeks after 4.0.3-rc1 release to see if anything (not specifically this) came up and this was not the case, so pushed out 4.0.3 :)

Issue History

Date Modified Username Field Change
2016-04-24 01:56 static-x New Issue
2016-04-24 02:21 static-x Note Added: 0019215
2016-04-24 10:26 syzop Note Added: 0019216
2016-04-24 10:51 syzop Note Added: 0019217
2016-04-24 10:51 syzop Status new => resolved
2016-04-24 10:51 syzop Fixed in Version => 4.0.3.1
2016-04-24 10:51 syzop Resolution open => fixed
2016-04-24 10:51 syzop Assigned To => syzop
2016-04-24 10:52 syzop Relationship added related to 0004663