View Issue Details

IDProjectCategoryView StatusLast Update
0004691unrealircdpublic2016-06-11 20:30
ReporterkweAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.0.3.1 
Target VersionFixed in Version4.0.4 
Summary0004691: ircd.motd cannot be found/read when specified in the files block
DescriptionI'm having this issue, that it says this on every rehash:

Loading IRCd configuration..
[warning] [installpath]/conf/unrealircd.conf:642: files::motd: ircd.motd: No such file or directory
Configuration loaded without any problems.

However, the file exists, and the /addmotd command even writes to the correct file; yet, rehash complains about it.
Steps To ReproduceAdd the relevant entry in unrealircd.conf:

files
{
        motd ircd.motd;
}

Comment out / remove any tld-blocks, if necessary.

Rehash.
Additional InformationBy commenting out the entire files-block, I was able to get UnrealIRCd to load the ircd.motd file.
TagsNo tags attached.
3rd party modules

Activities

Amiga600

2016-05-24 10:29

reporter   ~0019283

Funny enough, U4 does not have the files{} block in its default configuration file, I converted mine from U3 into U4 and it copied the files{} block without any issues, and the defaults I set in said files{} block works perfectly.

My files block is as follows and works perfect in U4:

files
{
    motd motd.txt;
        #shortmotd motd-short.txt;
    opermotd motd-oper.txt;
    botmotd motd-bot.txt;
    rules motd-rules.txt;
};

syzop

2016-05-24 12:52

administrator   ~0019285

kwe: where did you put your ircd.motd exactly? (on the filesystem)

kwe

2016-05-24 20:59

reporter   ~0019288

syzop: Next to the unrealircd.conf.
As in, the warning says "[installpath]/conf/unrealircd.conf", the motd file is at "[installpath]/conf/ircd.motd".

syzop

2016-05-24 21:16

administrator   ~0019291

Ok I tried to reproduce your issue...
Funny. I see the error message about ircd.motd but the MOTD is read correctly (seen on IRC) :D

syzop

2016-05-24 21:18

administrator   ~0019292

I've updated the subject, as it turns out it's working and just a confusing error message. I know why.. will fix later ;)

kwe

2016-05-24 21:27

reporter   ~0019293

That's not entirely correct, though. The MOTD didn't show up, it just said that the MOTD is missing, even when manually using the /motd command.

syzop

2016-05-25 10:17

administrator   ~0019294

Last edited: 2016-05-25 10:17

View 2 revisions

Apologies, I had a tld block which confused things (made it work). Subject changed back.

syzop

2016-06-11 20:30

administrator   ~0019314

Fixed, thanks for the report.

[unreal40 5f232da] Fix bug where files { } block only worked with absolute paths. Reported by kwe (0004691).
https://github.com/unrealircd/unrealircd/commit/5f232da4bb9b73ee8a077376dd04fd4f0495aac0

Issue History

Date Modified Username Field Change
2016-05-24 09:25 kwe New Issue
2016-05-24 10:29 Amiga600 Note Added: 0019283
2016-05-24 12:52 syzop Note Added: 0019285
2016-05-24 20:59 kwe Note Added: 0019288
2016-05-24 21:16 syzop Note Added: 0019291
2016-05-24 21:18 syzop Note Added: 0019292
2016-05-24 21:18 syzop Status new => confirmed
2016-05-24 21:18 syzop Summary ircd.motd cannot be found/read when specified in the files block => files block: confusing not found error message but working nonetheless
2016-05-24 21:27 kwe Note Added: 0019293
2016-05-25 10:17 syzop Note Added: 0019294
2016-05-25 10:17 syzop Summary files block: confusing not found error message but working nonetheless => ircd.motd cannot be found/read when specified in the files block
2016-05-25 10:17 syzop Note Edited: 0019294 View Revisions
2016-06-11 20:30 syzop Note Added: 0019314
2016-06-11 20:30 syzop Status confirmed => resolved
2016-06-11 20:30 syzop Fixed in Version => 4.0.4
2016-06-11 20:30 syzop Resolution open => fixed
2016-06-11 20:30 syzop Assigned To => syzop