View Issue Details

IDProjectCategoryView StatusLast Update
0004755unrealinstallingpublic2016-09-30 13:44
ReporterivanpAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOS Version
Product Version 
Target VersionFixed in Version4.0.7 
Summary0004755: Configuration files overwritten after "make install"
Descriptionbadwords.conf, dccallow.conf and spamfilter.conf are overwritten every time "make install" is executed.

Probably those should be renamed to badwords.default.conf, dccallow.default.conf and spamfilter.default.conf to avoid this from happening.
TagsNo tags attached.
3rd party modules

Activities

syzop

2016-09-29 09:25

administrator   ~0019424

Hmm that isn't good :D

The XYZ.default.conf would be best indeed, as we did with other files. But I'd prefer not to do that in 4.0.x to avoid clutter.
Easiest would be not to overwrite the files. This is acceptable since last time we touched either files has been ages ago[*].
In that respect there's quite a difference with the modules.default.conf and operclass.default.conf files which will very likely receive updates every year/whatever.

[*] apart from the 3.2->4.0 configuration format upgrade

syzop

2016-09-29 09:26

administrator   ~0019425

NOTE to self: fix both in Makefile -and- in Windows .iss file.

syzop

2016-09-30 13:44

administrator   ~0019432

Thanks, fixed in 4.0.7(-rc1)

https://github.com/unrealircd/unrealircd/commit/ea3ac462d1fea8a0f49bbe86bcf375309209efb8

Issue History

Date Modified Username Field Change
2016-09-28 21:05 ivanp New Issue
2016-09-29 09:25 syzop Note Added: 0019424
2016-09-29 09:26 syzop Note Added: 0019425
2016-09-29 09:26 syzop Status new => acknowledged
2016-09-30 13:44 syzop Note Added: 0019432
2016-09-30 13:44 syzop Status acknowledged => resolved
2016-09-30 13:44 syzop Fixed in Version => 4.0.7
2016-09-30 13:44 syzop Resolution open => fixed
2016-09-30 13:44 syzop Assigned To => syzop