View Issue Details

IDProjectCategoryView StatusLast Update
0004779unrealinstallingpublic2016-11-17 10:04
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSFreeBSDOS Version11
Product Version4.0.8.4 
Target VersionFixed in Version 
Summary0004779: UnrealIRCd does not compile --with-system-cares
DescriptionA user reports he is unable to compile UnrealIRCd. He uses --with-system-tre --with-system-pcre2 --with-system-cares on FreeBSD 11.x
TagsNo tags attached.
3rd party modules

Activities

syzop

2016-11-16 18:42

administrator   ~0019527

Seems build breaks with --with-system-cares. Then again, this option should no longer be specified since the default is autodetect (and use it if usable).

Also may have been a simple lack of pkg-config on the system. Checking...

syzop

2016-11-16 18:54

administrator   ~0019528

Last edited: 2016-11-16 18:54

View 2 revisions

It's simple: --with-system-cares always breaks the build.
Bug in configure script

syzop

2016-11-17 10:04

administrator   ~0019532

[unreal40 60d14e7] Fix broken build --with-system-cares. Specifying this option is no longer useful as it is the default in 4.0.8+. However, it shouldn't break the build if specified. Fixed damn silly reversed logic at a few places that caused this...
https://github.com/unrealircd/unrealircd/commit/60d14e7dcc8d2b649226f8834cadb9a76be78d0f

Issue History

Date Modified Username Field Change
2016-11-16 18:09 syzop New Issue
2016-11-16 18:42 syzop Note Added: 0019527
2016-11-16 18:42 syzop Summary UnrealIRCd does not compile w/... => UnrealIRCd does not compile --with-system-cares
2016-11-16 18:54 syzop Assigned To => syzop
2016-11-16 18:54 syzop Status new => confirmed
2016-11-16 18:54 syzop Note Added: 0019528
2016-11-16 18:54 syzop Note Edited: 0019528 View Revisions
2016-11-17 10:04 syzop Status confirmed => resolved
2016-11-17 10:04 syzop Resolution open => fixed
2016-11-17 10:04 syzop Note Added: 0019532