View Issue Details

IDProjectCategoryView StatusLast Update
0004882unrealircdpublic2017-10-18 15:26
ReporterdyfrgiAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOS Version
Product Version4.0.9 
Target VersionFixed in Version4.0.16 
Summary0004882: isupport does not update maxbans
DescriptionWhen rehashing the config with a new value, maxbans does not update in the ISUPPORT MAXLIST (numeric 005) returned by the server.
Steps To ReproduceStart Unreal
Observer current maxbans in ISUPPORT return (/VERSION, or look on connect)
Edit maxbans in set block
Rehash
/VERSION or reconnect
Additional InformationLooks like IsupportSetValue was missed in s_conf.c. Confirmed code is still the same in 4.0.11, I assume the bug is still present.
TagsNo tags attached.
3rd party modules

Activities

syzop

2017-10-18 15:26

administrator   ~0019926

Thanks for the report.

commit f8cab0d093c3b435f3eee9f568a2e224571ff762
Author: Bram Matthys <syzop@vulnscan.org>
Date: Wed Oct 18 15:22:33 2017 +0200

    isupport does not update maxbans. Reported by dyfrgi (0004882).

https://github.com/unrealircd/unrealircd/commit/f8cab0d093c3b435f3eee9f568a2e224571ff762

Issue History

Date Modified Username Field Change
2017-02-20 16:57 dyfrgi New Issue
2017-10-18 15:26 syzop Assigned To => syzop
2017-10-18 15:26 syzop Status new => resolved
2017-10-18 15:26 syzop Resolution open => fixed
2017-10-18 15:26 syzop Fixed in Version => 4.0.16
2017-10-18 15:26 syzop Note Added: 0019926