View Issue Details

IDProjectCategoryView StatusLast Update
0004894unrealircdpublic2017-03-13 08:35
Reporteruser7695Assigned Tosyzop 
PrioritylowSeveritytrivialReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version4.0.10 
Target VersionFixed in Version 
Summary0004894: Channels user count and the user count displayed in /LIST are different.
DescriptionI'm not sure if its intentional or an oversight, but when joining #unreal-support, I noticed there were only 17 clients. To me, this seemed a lot less than usual, on issuing /LIST to make sure I was in the right channel, I noticed LIST says there are 67 users in the channel.

#unreal-support also has +D (delayjoin) set, so there are obviously 67 people, 50 of whom haven't spoke since they joined.
TagsNo tags attached.
3rd party modules

Activities

syzop

2017-03-13 08:35

administrator   ~0019688

That is true. The user count in LIST is the real user count, it can be more than the users you are currently seeing.

I've no plans to change this as the purpose of delay join is "delaying joins" and not "hiding of users" or that kind of things. (Strictly speaking the real user count is also the real amount of users :D)

Similarly you can /WHOIS a user and see (s)he is in #somechan in /WHOIS but still don't see that user in the nicklist (NAMES).

Issue History

Date Modified Username Field Change
2017-03-12 05:18 user7695 New Issue
2017-03-13 08:35 syzop Assigned To => syzop
2017-03-13 08:35 syzop Status new => resolved
2017-03-13 08:35 syzop Resolution open => no change required
2017-03-13 08:35 syzop Note Added: 0019688