View Issue Details

IDProjectCategoryView StatusLast Update
0004906unrealircdpublic2017-03-27 08:56
ReporterNoMiausAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version4.0.11 
Target VersionFixed in Version4.0.12 
Summary0004906: Server sets +b even if the ban list is full when using +f
DescriptionBan list is full but server can set bans with +f protection. There's a commit to fix it but it didn't fix it: https://github.com/unrealircd/unrealircd/commit/55af9ec0a98e7149989a4d95c3626bb4e02a7b91
Steps To Reproduce1. Ban list is full.
2. Set +f.
3. Flood.
4. Enjoy!
TagsNo tags attached.
3rd party modules

Activities

syzop

2017-03-26 15:50

administrator   ~0019714

[unreal40 0035caf] Fix server setting +b even if the ban list is full when using +f. Reported by NoMiaus (0004906).
https://github.com/unrealircd/unrealircd/commit/0035cafdbae8d93605b359a9d07104140a277882

Thanks for the report :)

NoMiaus

2017-03-26 20:44

reporter   ~0019715

It isn't fixed yet. Now server sets the ban and kick but the ban it isn't added to the list (because it's full). The server shouldn't set the ban if it can't be added. Weird...

NoMiaus

2017-03-26 20:57

reporter   ~0019716

Sorry, my mistake. It's fixed. You can close the report again. Thank you :)

syzop

2017-03-27 08:56

administrator   ~0019717

Good. I thought for a moment that I missed something obvious during my testing :D

Issue History

Date Modified Username Field Change
2017-03-25 00:58 NoMiaus New Issue
2017-03-26 15:50 syzop Assigned To => syzop
2017-03-26 15:50 syzop Status new => resolved
2017-03-26 15:50 syzop Resolution open => fixed
2017-03-26 15:50 syzop Fixed in Version => 4.0.12
2017-03-26 15:50 syzop Note Added: 0019714
2017-03-26 20:44 NoMiaus Status resolved => feedback
2017-03-26 20:44 NoMiaus Resolution fixed => reopened
2017-03-26 20:44 NoMiaus Note Added: 0019715
2017-03-26 20:57 NoMiaus Note Added: 0019716
2017-03-27 08:56 syzop Status feedback => closed
2017-03-27 08:56 syzop Resolution reopened => fixed
2017-03-27 08:56 syzop Note Added: 0019717