View Issue Details

IDProjectCategoryView StatusLast Update
0004907unrealircdpublic2017-03-28 21:16
ReporterNoMiausAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.0.12 
Summary0004907: Jumpserver command doesn't redirect SSL users to the port set as SSL
DescriptionThis has been tested with mIRC, which should work according to the documentation.
SSL users aren't redirected to the choosen SSL port. Users are redirected by the way a regular port does: the IRC client tries 'IP (6697)' instead of 'IP (+6697)'. A symbol + is needed to work correctly.
Trying to set the command with the '+' results the same because the symbol is ignored by the module.
Steps To ReproduceCommand:
/JUMPSERVER IP:6667/IP:6697 ALL Reason

Result:
* Connecting to IP (6697)
* Unable to connect to server (Connection refused)
TagsNo tags attached.
3rd party modules

Activities

syzop

2017-03-26 15:39

administrator   ~0019713

Ah, it had old 3.2.x related stuff that wasn't converted properly for use with UnrealIRCd 4.x. Thanks for the report :)

https://github.com/unrealircd/unrealircd/commit/b6f8ddd4568359e27cca86cf7d90466de9fa8c66

[unreal40 b6f8ddd] Fix Jumpserver not working for SSL users due to old #ifdef USE_SSL. Reported by NoMiaus (0004907).

Issue History

Date Modified Username Field Change
2017-03-25 02:43 NoMiaus New Issue
2017-03-26 15:39 syzop Assigned To => syzop
2017-03-26 15:39 syzop Status new => resolved
2017-03-26 15:39 syzop Resolution open => fixed
2017-03-26 15:39 syzop Fixed in Version => 4.0.12
2017-03-26 15:39 syzop Note Added: 0019713