View Issue Details

IDProjectCategoryView StatusLast Update
0004915unrealircdpublic2017-10-18 15:44
ReporterEmanAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionduplicate 
Product Version4.0.9 
Target VersionFixed in Version4.0.16 
Summary0004915: missing server name in link rejection message
Description[2017/03/28 - 3:22:43PM] -coruscant.r-type.ca- *** Rejecting link [@172.16.20.14.49359]: our clock is 18002 seconds ahead. Correct time is very important in IRC. Please verify the clock on both (them) and coruscant.r-type.ca (us), fix it and then try linking again


looks like sptr->name on either/or/both lines 401 and 407 of m_protoctl.c isnt getting populated
TagsNo tags attached.
3rd party modules

Relationships

duplicate of 0004590 resolvedsyzop warning is missing server name 

Activities

syzop

2017-10-18 15:44

administrator   ~0019928

commit 5bedeaa9bfe9841a49e5fc6e9228a42e513c9e8e
Author: Bram Matthys <syzop@vulnscan.org>
Date: Wed Oct 18 15:43:13 2017 +0200

    Set cptr->name after EAUTH. Fixes bug 0004915 reported by Eman:
    missing server name in link rejection message (clock mismatch).

Issue History

Date Modified Username Field Change
2017-03-28 21:27 Eman New Issue
2017-10-18 15:44 syzop Relationship added duplicate of 0004590
2017-10-18 15:44 syzop Assigned To => syzop
2017-10-18 15:44 syzop Status new => resolved
2017-10-18 15:44 syzop Resolution open => duplicate
2017-10-18 15:44 syzop Fixed in Version => 4.0.16
2017-10-18 15:44 syzop Note Added: 0019928