View Issue Details

IDProjectCategoryView StatusLast Update
0004919unrealircdpublic2017-10-08 18:22
ReporterNoMiausAssigned Tosyzop 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.0.11 
Target VersionFixed in Version4.0.16 
Summary0004919: When log is full, the ircd doesn't write 'Max file size reached, starting new log file' message
DescriptionLog is renamed but 'Max file size reached, starting new log file' isn't written. I think the ircd is trying to write that line before opening the file. Check this commit: https://github.com/unrealircd/unrealircd/commit/3d60e89e546609706d039fa18f9f62bbd3941a40
TagsNo tags attached.
3rd party modules

Activities

syzop

2017-04-07 20:55

administrator   ~0019737

You're saying it isn't being written to the old log file? (That's the idea)

syzop

2017-09-15 10:26

administrator   ~0019872

noresponse

NoMiaus

2017-09-17 01:45

reporter   ~0019873

Yes. The line 'Max file size reached, starting new log file' isn't written anywhere and according to the commit it should.

syzop

2017-10-08 18:13

administrator   ~0019905

Turns out it does work OK while the IRCd is running (The Max file size reached[..] line is written).
But it does not work if during startup of the ircd the file size is exceeded, then it doesn't write the message.

syzop

2017-10-08 18:22

administrator   ~0019906

commit f2603cdc49bf5989c7ba58d51d0278356ad00d95
Author: Bram Matthys <syzop@vulnscan.org>
Date: Sun Oct 8 18:19:16 2017 +0200

    When booting the IRCd and the log is full (log::maxfilesize), the IRCd
    would not write the appropriate 'Max file size reached' message to the
    old log file. Reported by NoMiaus (0004919).

https://github.com/unrealircd/unrealircd/commit/f2603cdc49bf5989c7ba58d51d0278356ad00d95

Issue History

Date Modified Username Field Change
2017-03-30 01:25 NoMiaus New Issue
2017-03-30 20:09 syzop Severity minor => tweak
2017-04-07 20:54 syzop Status new => acknowledged
2017-04-07 20:55 syzop Note Added: 0019737
2017-09-15 10:26 syzop Assigned To => syzop
2017-09-15 10:26 syzop Status acknowledged => closed
2017-09-15 10:26 syzop Resolution open => unable to reproduce
2017-09-15 10:26 syzop Note Added: 0019872
2017-09-17 01:45 NoMiaus Status closed => feedback
2017-09-17 01:45 NoMiaus Resolution unable to reproduce => reopened
2017-09-17 01:45 NoMiaus Note Added: 0019873
2017-10-08 18:13 syzop Note Added: 0019905
2017-10-08 18:13 syzop Assigned To syzop =>
2017-10-08 18:13 syzop Status feedback => confirmed
2017-10-08 18:22 syzop Assigned To => syzop
2017-10-08 18:22 syzop Status confirmed => resolved
2017-10-08 18:22 syzop Note Added: 0019906
2017-10-08 18:22 syzop Resolution reopened => fixed
2017-10-08 18:22 syzop Fixed in Version => 4.0.16