View Issue Details

IDProjectCategoryView StatusLast Update
0004949unrealircdpublic2017-10-11 18:29
ReporterMewsitoAssigned Tosyzop 
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.0.11 
Target VersionFixed in Version4.0.16 
Summary0004949: user mode -r
DescriptionFirst of all, I'm sorry for English ... I'm Spanish ... and this is translated

When a user identifies himself before the services, they send a SVS2MODE X +r
* services.server sets mode: +r

When this user changes nick, the services send a SVS2MODE X -r

But the user does not receive the warning from the server, and it stays like it has + r although it does not really have it, if it is done a COMMAND it is seen that it does not have the mode r
Steps To ReproduceEasy
send a SVS2MODE X +r
and then a SVS2MODE X -r

X = nick of user
Tagsmode, nick
3rd party modules

Activities

Mewsito

2017-05-12 17:51

reporter   ~0019771

COMMAND in the last line is /whois X

syzop

2017-10-11 18:29

administrator   ~0019925

Thanks for the report.

https://github.com/unrealircd/unrealircd/commit/307243ff7abad6ca6b76ac3e51078b87dd7ec214

UnrealIRCd does the -r when you nick-change, but it didn't show it.
Then, by the time the SVS2MODE or SVSMODE -r was received it would not show it again since it was already unste.

The change in the code is that UnrealIRCd will now show the -r. No need to send a SVSMODE/SVS2MODE for it.

Issue History

Date Modified Username Field Change
2017-05-12 17:38 Mewsito New Issue
2017-05-12 17:38 Mewsito Tag Attached: mode
2017-05-12 17:38 Mewsito Tag Attached: nick
2017-05-12 17:51 Mewsito Note Added: 0019771
2017-10-11 18:29 syzop Assigned To => syzop
2017-10-11 18:29 syzop Status new => resolved
2017-10-11 18:29 syzop Resolution open => fixed
2017-10-11 18:29 syzop Fixed in Version => 4.0.16
2017-10-11 18:29 syzop Note Added: 0019925