View Issue Details

IDProjectCategoryView StatusLast Update
0004980unrealircdpublic2017-09-08 07:42
Reportermarco500Assigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnreal 4.0.12OSUbuntuOS VersionUbuntu 16.04
Product Version4.0.12 
Target VersionFixed in Version4.0.14 
Summary0004980: +N is not allowed for modes-on-connect even with the module noinvites added..
DescriptionThere is a module I have called No invites that uses usermode +N. I want to add that to modes-on-connect but it gives on error for +N. Please change to allow for +N to be added there... Thanks pooh bear..
Steps To ReproduceJust adding +N on modes-on-connect and you will see sexy..
TagsNo tags attached.
3rd party modules

Activities

syzop

2017-09-06 08:56

administrator   ~0019838

Could it be that your noinvites module doesn't add the usermode in MOD_INIT()?
If it adds it in MOD_LOAD() then it will be "too late", since set_usermodes() is already called from the code handing set::modes-on-connect.

Gottem

2017-09-07 08:09

reporter   ~0019841

Nah, m_noinvite does add it inside MOD_INIT. The problem lies here (src/s_conf:7654):

for (p = cep->ce_vardata; *p; p++)
    if (strchr("oOaANCrzSgHhqtW", *p)) {
        config_error("%s:%i: set::modes-on-connect may not include mode '%c'",

Notice how +N is contained in the first arg of strchr(). =]

marco500

2017-09-07 15:01

reporter   ~0019842

If Gottem knew how to code this would have NEVER HAPPENED!! sigh.

syzop

2017-09-08 07:42

administrator   ~0019843

Just in time for 4.0.14-rc1

commit 461ce8016ae240dd4dea27e9d58de06db4c1575f
Author: Bram Matthys <syzop@vulnscan.org>
Date: Fri Sep 8 07:39:56 2017 +0200

    Some modes in set::modes-on-connect gave an error. These were
    old user modes such as +N and +A that were previously forbidden but
    may nowadays be (re-)used by 3rd party modules.
    Reported by marco500 (0004980).

https://github.com/unrealircd/unrealircd/commit/461ce8016ae240dd4dea27e9d58de06db4c1575f

Issue History

Date Modified Username Field Change
2017-08-05 06:10 marco500 New Issue
2017-08-10 08:36 syzop Priority high => normal
2017-08-15 12:10 syzop Severity major => minor
2017-09-06 08:56 syzop Note Added: 0019838
2017-09-06 08:59 syzop Status new => feedback
2017-09-07 08:09 Gottem Note Added: 0019841
2017-09-07 15:01 marco500 Note Added: 0019842
2017-09-08 07:42 syzop Assigned To => syzop
2017-09-08 07:42 syzop Status feedback => resolved
2017-09-08 07:42 syzop Resolution open => fixed
2017-09-08 07:42 syzop Fixed in Version => 4.0.14
2017-09-08 07:42 syzop Note Added: 0019843