View Issue Details

IDProjectCategoryView StatusLast Update
0004997unrealircdpublic2017-10-18 15:27
ReporterGottemAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.0.13 
Target VersionFixed in Version4.0.16 
Summary0004997: /stats S not showing entire block
DescriptionOriginally encountered by Koragg.

It seems /stats S doesn't return _all_ variables contained within the set { } block. I looked at the code for m_stats and stats_set() doesn't actually iterate through the block, but is simply hardcoded to spit out certain variables.

An example of a missing variable would be sasl-server (I haven't checked for others tbh). I don't know if it's by design that you're not iterating, but it might get confusing. =] Especially in this case since SASL is slowly becoming more popular.

Think it's present in any release of v4.x, but I know for sure it applies to 4.0.10 and 4.0.13.
TagsNo tags attached.
3rd party modulesN/A

Activities

syzop

2017-09-06 08:39

administrator   ~0019837

That is unfortunately how it works in C. You cannot "iterate through the block" and for each setting you have to mention how it should be outputted as it could be a string, integer, enum, another sub-struct, etc.

Now you understand why it's such a pain ;)

I'll see if I can add sasl-server, though.

Gottem

2017-09-06 19:26

reporter   ~0019840

Nah I know you can't just do that, but I thought maybe you could figure something out (might get hacky tho lol). :>

syzop

2017-10-18 15:27

administrator   ~0019927

Roger :)

And since sasl server is now added, I'm closing this one.

Issue History

Date Modified Username Field Change
2017-09-06 00:44 Gottem New Issue
2017-09-06 08:39 syzop Note Added: 0019837
2017-09-06 19:26 Gottem Note Added: 0019840
2017-10-18 15:27 syzop Assigned To => syzop
2017-10-18 15:27 syzop Status new => closed
2017-10-18 15:27 syzop Resolution open => fixed
2017-10-18 15:27 syzop Fixed in Version => 4.0.16
2017-10-18 15:27 syzop Note Added: 0019927
2017-10-18 15:27 syzop Status closed => resolved