View Issue Details

IDProjectCategoryView StatusLast Update
0005011unrealircdpublic2017-10-07 09:03
Reportermarco500Assigned Tosyzop 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
PlatformunrealOSlinux sexy dogggOS Versionubuntu linux
Product Version4.0.14 
Target VersionFixed in Version4.0.16 
Summary0005011: move some settings from config.h to the conf
Descriptionmove fakelag, maxunknownconnectionsperip, and connection timeout from config.h to the conf
Steps To Reproduce...
Additional Information...
TagsNo tags attached.
3rd party modules

Activities

Amiga600

2017-09-27 23:30

reporter   ~0019888

Personally I would also consider moving PREFIX_AQ to the config as well, so users can choose if they want the full PREFIX=~&@%+(qaohv) or the minimal PREFIX=@%+(ohv) - as U3 used to do, the qa modes would still exist, but would not give out a mode symbol for those letters.

syzop

2017-10-07 08:47

administrator   ~0019891

[unreal40 d6acbf6] Move MAXUNKNOWNCONNECTIONSPERIP to set::max-unknown-connections-per-ip. Rarely tweaked setting, but for those who need it it's easier in the conf. Requested by marco500 (0005011). For documentation of this setting see: https://www.unrealircd.org/docs/Set_block#set::max-unknown-connections-per-ip

[unreal40 7a33a2c] Move CONNECTTIMEOUT to set::handshake-timeout and clarify the setting at https://www.unrealircd.org/docs/Set_block#set::handshake-timeout Requested by marco500 in 0005011.

https://github.com/unrealircd/unrealircd/commit/d6acbf63b012f3a858b15fd8f84e68b6304bee6d

https://github.com/unrealircd/unrealircd/commit/7a33a2c019b27348e490c66c3f1ebc132bf7cedf

syzop

2017-10-07 09:00

administrator   ~0019892

Last edited: 2017-10-07 09:03

View 2 revisions

I've moved some of the requested settings to the config file. Hope you're happy with that.

I did not move fakelag. This is a very dangerous setting which basically disables the most important security measure the IRCd has. When adding this we made the decision to put it in config.h to extra highlight this. I still agree with that.

As for PREFIX_AQ. I really don't like non-prefixaq where +q and +a still exist but not the symbol. It's highly confusing. Back when preparing 4.0.0 we considered two options: put a lot of effort in moving +qa to a module (not just the symbol, but the entire mode AND symbols) or just making PREFIX_AQ mandator for everyone. Since moving the stuff to a module was wayyyy to much work and it wouldn't satisfy people (like you) who want +qa but not as a symbol, we left it as an #ifdef. So, I guess that's a sortof "you should be happy it's still there as an option". And yeah, don't worry I won't pull it out in some next release
Anyway, another argument is that you should really set this setting on or off and stick by it and implement it network-wide. It's not good to change it dynamically, which is where the configuration file is for.

Issue History

Date Modified Username Field Change
2017-09-16 10:17 marco500 New Issue
2017-09-16 18:21 syzop Summary can you move fakelag, maxunknownconnectionsperip, and connection timeout from config.h to the conf? => move some settings from config.h to the conf
2017-09-16 18:21 syzop Description Updated View Revisions
2017-09-27 23:30 Amiga600 Note Added: 0019888
2017-10-07 08:47 syzop Note Added: 0019891
2017-10-07 09:00 syzop Assigned To => syzop
2017-10-07 09:00 syzop Status new => resolved
2017-10-07 09:00 syzop Resolution open => fixed
2017-10-07 09:00 syzop Fixed in Version => 4.0.16
2017-10-07 09:00 syzop Note Added: 0019892
2017-10-07 09:03 syzop Note Edited: 0019892 View Revisions