View Issue Details

IDProjectCategoryView StatusLast Update
0005013unrealircdpublic2017-09-20 15:54
ReporterThe_MythAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSUbuntuOS Version16.04 LTS
Product Version 
Target VersionFixed in Version4.0.15 
Summary0005013: Connection seen as localhost
DescriptionI'm experiencing the following issue:
Lets assume that the IP is 123.456.789.0
When connecting with a znc (with the znc bindhost set to the IP above) to the IRC server (accepting connections on same IP), the connection is seen as 'nick!ident@localhost'.
I've tried it on a fresh install of UnrealIRCd 4.0.14 without no other modules than the others shipped by default (didnt even edited them, and also no services).
As i was using webirc blocks on my production server I've thought that could be the issue.
Therefore I've set up the testnet and the issue remains.
Steps To ReproduceJust setup a znc on the same machine as the IRC server and set the znc bindhost to, i.e, the ipv4 address of the IRC server.
That should do it
TagsNo tags attached.
3rd party modules

Activities

The_Myth

2017-09-19 21:24

reporter   ~0019874

Side note:
I'm connecting to the IRC server using external IP and not via localhost

syzop

2017-09-20 09:11

administrator   ~0019875

I can see how I introduced that mistake in 4.0.14. I'll fix that.

You set the severity to 'major' and priority to 'high'. What is the reason for that? (Just in case I'm overlooking something)

The_Myth

2017-09-20 12:13

reporter   ~0019876

I did that because I was unsure how that could affect the bans and glines and also because cloaking.

Best regards

syzop

2017-09-20 15:54

administrator   ~0019877

Fixed, thanks for the report :)

commit 638b189804065d75e0c3308c5b60300d1f2393ac
Author: Bram Matthys <syzop@vulnscan.org>
Date: Wed Sep 20 15:51:41 2017 +0200

    Users connecting to the IRC server from the same machine could be seen as
    "localhost", even though they were using an IP other than 127.0.0.1.
    So, they were local but not using loopback. Reported by The_Myth (0005013).

https://github.com/unrealircd/unrealircd/commit/638b189804065d75e0c3308c5b60300d1f2393ac

Issue History

Date Modified Username Field Change
2017-09-19 21:04 The_Myth New Issue
2017-09-19 21:24 The_Myth Note Added: 0019874
2017-09-20 09:11 syzop Note Added: 0019875
2017-09-20 12:13 The_Myth Note Added: 0019876
2017-09-20 15:44 syzop Priority high => normal
2017-09-20 15:44 syzop Severity major => minor
2017-09-20 15:44 syzop Status new => confirmed
2017-09-20 15:54 syzop Assigned To => syzop
2017-09-20 15:54 syzop Status confirmed => resolved
2017-09-20 15:54 syzop Resolution open => fixed
2017-09-20 15:54 syzop Fixed in Version => 4.0.15
2017-09-20 15:54 syzop Note Added: 0019877