View Issue Details

IDProjectCategoryView StatusLast Update
0005079unrealircdpublic2018-03-25 13:48
ReporteremersonAssigned Tosyzop 
PrioritylowSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.0.18 
Summary0005079: Change output of RPL_SNOMASK to have the snomask in a parameter
DescriptionRight now, the 008 RPL_SNOMASK numeric is sent as this:

:test.local 008 emerson :Server notice mask (+k)

Unreal is the only large IRCd that puts the mask in the trailing parameter, all the other IRCds that have snomasks put it as a separate parameter, like so:

:test.local 008 emerson +FZbcdfklrsuxy :Server notice mask

Having the mask in a separate parameter makes it easier for client developers to unambiguously parse the numeric, since it has a separate, dedicated parameter. It will also bring the numeric in line with the rest of the IRCds, so that client developers no longer have to special case this output.
Tagsnumeric, snomask
3rd party modules

Activities

syzop

2018-03-25 13:48

administrator   ~0020071

Good idea. Thanks for the report!

https://github.com/unrealircd/unrealircd/commit/894491fa3215c1d0c7e5e2a8470d8ee3bd8c369b

commit 894491fa3215c1d0c7e5e2a8470d8ee3bd8c369b
Author: Bram Matthys <syzop@vulnscan.org>
Date: Sun Mar 25 13:45:59 2018 +0200

    Change numeric 008 format which reports snomask.
    This is for easier parsing of the "MODE yournick" response.
    From:
    :maintest.test.net 008 testuser :Server notice mask (+kcfjvGqSso)
    To:
    :maintest.test.net 008 testuser +kcfjvGqSso :Server notice mask
    Reported by emerson in 0005079.

Issue History

Date Modified Username Field Change
2018-03-17 03:38 emerson New Issue
2018-03-17 03:38 emerson Tag Attached: numeric
2018-03-17 03:38 emerson Tag Attached: snomask
2018-03-25 13:48 syzop Assigned To => syzop
2018-03-25 13:48 syzop Status new => resolved
2018-03-25 13:48 syzop Resolution open => fixed
2018-03-25 13:48 syzop Fixed in Version => 4.0.18
2018-03-25 13:48 syzop Note Added: 0020071