View Issue Details

IDProjectCategoryView StatusLast Update
0005102unrealircdpublic2018-09-02 11:27
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version4.0.18 
Target Version4.2.0Fixed in Version4.2.0 
Summary0005102: Use newer compiler for Windows build
DescriptionProbably too late for 4.0.18, but for next UnrealIRCd version we should use a newer Visual Studio compiler, such as VS2017.
Checklist:
* Recompile all dependencies
* Update installer with UUID's for VS runtime package
* Test!!!
TagsNo tags attached.
3rd party modules

Activities

syzop

2018-07-14 16:23

administrator   ~0020194

I'm going to start with this first for 4.0.19, since it has long been overdue.
Once my development environment is back up, that is :)

syzop

2018-09-02 11:27

administrator   ~0020245

To my knowledge this has all been done on July 15 2018.

Except for more thorough testing by our non-existant QA team, but we never leave bug reports open for that...

Issue History

Date Modified Username Field Change
2018-06-13 08:18 syzop New Issue
2018-06-13 08:18 syzop Status new => confirmed
2018-06-23 08:38 syzop Target Version => 4.2.0
2018-07-14 16:23 syzop Note Added: 0020194
2018-07-14 16:23 syzop Assigned To => syzop
2018-07-14 16:23 syzop Status confirmed => assigned
2018-07-14 16:35 syzop Sticky Issue No => Yes
2018-09-02 11:27 syzop Status assigned => closed
2018-09-02 11:27 syzop Resolution open => fixed
2018-09-02 11:27 syzop Fixed in Version => 4.2.0
2018-09-02 11:27 syzop Note Added: 0020245
2018-09-02 11:27 syzop Status closed => resolved