View Issue Details

IDProjectCategoryView StatusLast Update
0005106unrealinstallingpublic2018-06-23 08:14
ReporterThe_MythAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSUbuntuOS Version16.04 LTS
Product Version4.0.17 
Target VersionFixed in Version4.0.18 
Summary0005106: Upgrading the IRCd normally leads to an error related to libcurl
DescriptionWhen upgrading UnrealIRCd normally, using ./Config, if you have chosen to enable remote includes in the last installation before upgrading, it will fail the upgrade with the following error:

checking /home/unrealircd/unrealircd-4.0.18-rc1/extras/curl/bin/curl-config... yes
checking curl_easy_init() in -L/home/unrealircd/unrealircd/lib -lcurl... no
configure: error: in `/home/unrealircd/unrealircd-4.0.18-rc2':
configure: error: You asked for libcURL (remote includes) support, but it can't be found at /home/unrealircd/unrealircd-4.0.18-rc1/extras/curl
Steps To Reproduce1) Download the latest version available of UnrealIRCd, untar it and enter into the uncompressed folder

2) Type ./Config and hit enter in all the questions

3) UnrealIRCd will fail the upgrade with the error stated in the description (assuming that you have enabled remote includes in the other installation, otherwise it will upgrade without any errors)
TagsNo tags attached.
3rd party modules

Activities

syzop

2018-06-18 08:26

administrator   ~0020163

I see, I have an idea what causes this... will take a look later.
(No need to provide any further information)

syzop

2018-06-23 08:14

administrator   ~0020177

Fixed in upcoming 4.0.18. Thanks for the report!

commit 05dcf18ea621a8009b8ee0f2cdcb727c8b3636c1
Author: Bram Matthys <syzop@vulnscan.org>
Date: Sat Jun 23 08:13:02 2018 +0200

    When importing ./Config settings from a previous UnrealIRCd, with
    curl enabled but without system curl, the build could fail with
    an libCURL configure error. This is is because it imported the
    CURLDIR but it referred to an old UnrealIRCd directory.
    Reported by The_Myth (0005106)


Issue History

Date Modified Username Field Change
2018-06-16 23:55 The_Myth New Issue
2018-06-18 08:26 syzop Assigned To => syzop
2018-06-18 08:26 syzop Status new => acknowledged
2018-06-18 08:26 syzop Note Added: 0020163
2018-06-23 08:00 syzop Status acknowledged => assigned
2018-06-23 08:14 syzop Status assigned => resolved
2018-06-23 08:14 syzop Resolution open => fixed
2018-06-23 08:14 syzop Fixed in Version => 4.0.18
2018-06-23 08:14 syzop Note Added: 0020177