View Issue Details

IDProjectCategoryView StatusLast Update
0005143unrealmodule apipublic2018-09-20 20:03
ReporterGottemAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.2.0 
Summary0005143: Priorities for CmdOverrides
DescriptionI currently have a few modules implementing command overrides, one of which needs to be changed to not call _other_ overrides anymore. So this one should always be processed last, but there's currently no way to assign priorities like you can with hooks.

This is in relation to PeGaSuS's report about m_fixhop throwing duplicate errors. My override for INVITE also runs CallCmdOverride() (because I have other INVITE overrides too), but eventually the m_invite CMD_FUNC will be called which throws the "cannot invite" error. Due to my override the INVITE may already be sent to another server, which does the same checks and also returns an error. So this results in 2 errors from 2 different servers but the invite actually went through. :D

So I was thinking to just have m_fixhop's override run as the very last thing and return 0 instead of CallCmdOverride. =]
TagsNo tags attached.
3rd party modules

Activities

syzop

2018-09-20 20:03

administrator   ~0020338

Thanks, added. I will actually need this for WHOX, hence the fast commit :D

commit 30da2ae5530b5ec8fb66ea694d81a73fcb5cc8d1 (HEAD -> unreal40, origin/unreal40, origin/HEAD)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Thu Sep 20 20:01:39 2018 +0200

    Module devs: Add priorities for command overrides.
    Use: CmdoverrideAddEx(module, name, priority, function)
    Suggested by Gottem in https://bugs.unrealircd.org/view.php?id=5143
    ..and needed by some upcoming stuff.

Issue History

Date Modified Username Field Change
2018-09-13 11:31 Gottem New Issue
2018-09-20 20:03 syzop Assigned To => syzop
2018-09-20 20:03 syzop Status new => resolved
2018-09-20 20:03 syzop Resolution open => fixed
2018-09-20 20:03 syzop Fixed in Version => 4.2.0
2018-09-20 20:03 syzop Note Added: 0020338