View Issue Details

IDProjectCategoryView StatusLast Update
0005149unrealircdpublic2018-09-21 09:21
ReporterfbiAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.2.0 
Summary0005149: ciphersuites support for TLSv1.3
DescriptionThis is required for setting ciphers priority for TLS 1.3
TagsNo tags attached.
3rd party modules

Activities

fbi

2018-09-19 21:31

reporter  

u4_tls1.3_ciphersuites_support.diff (3,991 bytes)

syzop

2018-09-20 20:17

administrator   ~0020341

Thanks, merged!

ommit fb0148a44a56ed5589cebc93c2d369b9ed095bf9 (HEAD -> unreal40, origin/unreal40, origin/HEAD)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Thu Sep 20 20:14:18 2018 +0200

    New set::ssl::options::ciphersuites option for TLSv1.3.
    Since OpenSSL decided not to use the regular ciphers but make this a
    separate option, we now make this a separate option as well.
    So there is ::ciphers for <=TLSv1.2 and ::ciphersuites for TLSv1.3
    More documentation will follow.
    Patch from 'i' in https://bugs.unrealircd.org/view.php?id=5149

Will leave bug open until I add the online docs for this (and write the release note entry)...

Issue History

Date Modified Username Field Change
2018-09-19 21:31 fbi New Issue
2018-09-19 21:31 fbi File Added: u4_tls1.3_ciphersuites_support.diff
2018-09-20 20:17 syzop Note Added: 0020341
2018-09-21 09:21 syzop Assigned To => syzop
2018-09-21 09:21 syzop Status new => resolved
2018-09-21 09:21 syzop Resolution open => fixed
2018-09-21 09:21 syzop Fixed in Version => 4.2.0