View Issue Details

IDProjectCategoryView StatusLast Update
0005169unrealircdpublic2018-12-19 13:51
ReportersyzopAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version4.2.1 
Target Version4.2.1Fixed in Version4.2.1 
Summary0005169: config: incorrect line number In error messages
DescriptionThe line number of the closing brace error message (maybe others too) is not correct. It's being offset by /* comments or something.

Best to first figure out if this is because one of my config parser changes or not.. before looking at it on a deeper level..

Setting to 'major' and release target, since this is something that can be really frustrating for users (being pointed to the wrong line).
TagsNo tags attached.
3rd party modules

Activities

syzop

2018-12-19 13:51

administrator   ~0020411

Yup, my fault. Fixed now.

commit 0ac56e44447f402df05941f9eb92e1df370e2d3f (HEAD -> unreal42, origin/unreal42)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Wed Dec 19 13:50:09 2018 +0100

    Fix line number in error messages being off, as reported in
    https://bugs.unrealircd.org/view.php?id=5169
    caused by commit 51ed51dff1177c0dd860145117167353ac1b89fb

Issue History

Date Modified Username Field Change
2018-12-14 17:30 syzop New Issue
2018-12-14 17:30 syzop Status new => confirmed
2018-12-14 17:31 syzop Description Updated View Revisions
2018-12-19 13:51 syzop Assigned To => syzop
2018-12-19 13:51 syzop Status confirmed => resolved
2018-12-19 13:51 syzop Resolution open => fixed
2018-12-19 13:51 syzop Fixed in Version => 4.2.1
2018-12-19 13:51 syzop Note Added: 0020411