View Issue Details

IDProjectCategoryView StatusLast Update
0005183unrealircdpublic2019-01-28 14:42
Reporterk4beAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version4.2.1 
Target VersionFixed in Version4.2.2-rc1 
Summary0005183: Transfer +beI original setters and setting times during server linking
DescriptionCurrently only masks are transferred with the SJOIN command (for example &a!b@c). The data about nick that set the mode, and when it has been set, is lost (the mode appears to be set by a server with a timestamp of the linking). The command could be tweaked to carry this info too.
TagsNo tags attached.
3rd party modules

Activities

syzop

2019-01-01 17:03

administrator   ~0020442

I did some digging and noticed that codemastr and I rejected the feature in 2005/2006 (0002471) with the reason: "would consume A LOT bandwidth for little use".
However, nowadays, this is not an issue anymore, so I'm willing to consider this request. I'll leave the technical discussion for another day (note to self: should take 0004372 into account as well).

Out of curiosity, wondering if 2006 was really that different than 2018, I grabbed some stats of the Dutch internet exchange AMS-IX to compare numbers:
Turns out there has been a 35x increase of traffic if you compare 2006 with 2018 (3500%). That doesn't necessarily mean that every server has a 35x bandwidth increase as well, but.. it does tell us some things definitely changed :)

syzop

2019-01-28 14:42

administrator   ~0020467

commit 874d99e0eb694a3fa9fe985d9ea81e12310ac1a5 (HEAD -> unreal42, origin/unreal42)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Mon Jan 28 14:36:41 2019 +0100

    For +beI lists the 'set by' and 'set at' information is now synchronized
    when servers link. Thus, you can see the real setter and time also after
    a netsplit (/mode #channel b). This, unlike before, when setby was
    name.of.server and time was the time of the synch.
    This requires the entire network to run UnrealIRCd 4.2.2 or later.
    Suggested by k4be in https://bugs.unrealircd.org/view.php?id=5183
    Technical details: the PROTOCTL token to enable this is "SJSBY" and see
    https://www.unrealircd.org/docs/Server_protocol:SJOIN_command for more
    information, in particular the last section there.

https://github.com/unrealircd/unrealircd/commit/874d99e0eb694a3fa9fe985d9ea81e12310ac1a5

Issue History

Date Modified Username Field Change
2018-12-31 15:05 k4be New Issue
2019-01-01 17:03 syzop Note Added: 0020442
2019-01-01 17:04 syzop Status new => acknowledged
2019-01-28 14:42 syzop Assigned To => syzop
2019-01-28 14:42 syzop Status acknowledged => resolved
2019-01-28 14:42 syzop Resolution open => fixed
2019-01-28 14:42 syzop Fixed in Version => 4.2.2-rc1
2019-01-28 14:42 syzop Note Added: 0020467