View Issue Details

IDProjectCategoryView StatusLast Update
0005236unrealircdpublic2019-04-14 11:15
ReporterThe_MythAssigned Tosyzop 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformUnixOSUbuntuOS Version18.04 LTS
Product Version4.2.2 
Target VersionFixed in Version 
Summary0005236: Spamfilter doesn't have any protection against "broad strings"
DescriptionIf we add a spamfilter like:
spamfilter add -simple cpnNPqadtu gline 1d Spam_/_Flood_/_Advertising_/_Other_abuses ***
all the users on the network will be G-Lined immediately.

There should exist some protection against that and at least against:
spamfilter add -regex cpnNPqadtu gline 1d Spam_/_Flood_/_Advertising_/_Other_abuses ^.*.*$ (not sure if this is correct)
Steps To ReproduceJust add a spamfilter like:
/spamfilter add -simple cpnNPqadtu gline 1d Spam_/_Flood_/_Advertising_/_Other_abuses ***
and watch everyone in the network being G-Lined immediately.
Tagsspamfilter
3rd party modules

Activities

syzop

2019-04-14 11:15

administrator   ~0020576

Duplicate of #2218, let's discuss there.
(No I don't blame you for not checking 200 bugs :D)

Issue History

Date Modified Username Field Change
2019-03-25 15:21 The_Myth New Issue
2019-03-25 15:21 The_Myth Tag Attached: spamfilter
2019-04-14 11:15 syzop Assigned To => syzop
2019-04-14 11:15 syzop Status new => closed
2019-04-14 11:15 syzop Resolution open => duplicate
2019-04-14 11:15 syzop Note Added: 0020576