View Issue Details

IDProjectCategoryView StatusLast Update
0005320unrealircdpublic2019-08-22 20:23
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version5.0.0-alpha2 
Summary0005320: U5: Windows 64 bit version
DescriptionIt is my intention to (only) provide a 64 bit Windows version with UnrealIRCd 5.

This way we can make the transition to 64 bit, while at the same time deprecate the 32 bit version. As everyone can understand, providing both a 32- and 64-bit version is more hassle, both for us and 3rd party module coders. We will have to move to 64 bit some day, and this seems like a perfect time to do so.

Windows 7 extended support will end at Jan 2020. While Windows 8.x and even Windows 10 do have a 32 bit version, it makes little sense to use such a version or to provide support for it, given that 32 bit only hardware is rare these days. Running 32 bit Windows version also means you are limited to 2GB, which is rather low-end hardware.
The last Windows Server version that had a 32 bit version was Windows Server 2008. For this version too, extended support will end at 14 January 2020 by Microsoft.

We only have a limited Windows userbase anyway. Best estimate (via IRCStats) is <150 UnrealIRCd servers running Windows (any XX bits version), of which <100 are on UnrealIRCd 4 (which shows a more accurate figure, since you are crazy if you are still running 3.2.x so years after the deprecation).
Statistics on 32-bit Windows are not made public by Microsoft. But for example steam hw survey publishes 1.3% at the moment. One has to take into account that game pc's will be newer of course, so let's put it at 5%.
So calculating 5% * 100 or 150, this would impact 5-10 users at most.

Seems like an affordable move ;)

For admins it will mean the UnrealIRcd directory will change, but for them it is unlikely to make much difference:
* If we were to stay 32 bit it would be "C:\Program Files (x86)\UnrealIRCd 4" to "C:\Program Files (x86)\UnrealIRCd 5"
* With the 64 bit move, it will be from "C:\Program Files (x86)\UnrealIRCd 4" to "C:\Program Files\UnrealIRCd 5"
TagsNo tags attached.
3rd party modules

Relationships

related to 0005322 resolvedsyzop U5: make Windows compile without compiler warnings 
child of 0005279 acknowledged UnrealIRCd 5 master tracking issue 

Activities

syzop

2019-06-22 12:56

administrator   ~0020738

Related: use /HIGHENTROPYVA for increased ASLR protection (only available on 64 bit)

syzop

2019-08-10 11:34

administrator   ~0020803

Bump

syzop

2019-08-22 20:22

administrator   ~0020841

Last edited: 2019-08-22 20:23

View 4 revisions

Done in current development version, which will be 5.0.0-alpha2 in the future. Took quite a few hours, actually.

/HIGHENTROPYVA is the default and so is (related) /DYNAMICBASE so we should be good wrt ASLR (or at least that's all we can do).

There are still some (Windows) 64 bit issues to be resolved (new warnings being triggered) but I will deal with them in 0005322.

Issue History

Date Modified Username Field Change
2019-06-22 12:54 syzop New Issue
2019-06-22 12:56 syzop Note Added: 0020738
2019-08-10 11:34 syzop Relationship added child of 0005279
2019-08-10 11:34 syzop Note Added: 0020803
2019-08-18 15:17 syzop View Status private => public
2019-08-18 15:55 syzop Relationship added related to 0005322
2019-08-18 15:56 syzop Status new => acknowledged
2019-08-22 20:22 syzop Assigned To => syzop
2019-08-22 20:22 syzop Status acknowledged => resolved
2019-08-22 20:22 syzop Resolution open => fixed
2019-08-22 20:22 syzop Fixed in Version => 5.0.0-alpha2
2019-08-22 20:22 syzop Note Added: 0020841
2019-08-22 20:23 syzop Note Edited: 0020841 View Revisions
2019-08-22 20:23 syzop Note Edited: 0020841 View Revisions
2019-08-22 20:23 syzop Note Edited: 0020841 View Revisions