View Issue Details

IDProjectCategoryView StatusLast Update
0005325unrealircdpublic2019-07-01 17:45
ReporterThe_MythAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSUbuntuOS Version18.04 LTS
Product Version4.2.3 
Target VersionFixed in Version5.0.0-alpha1 
Summary0005325: EXTBAN ~T could block part/quit messages containing the blocked words
DescriptionWhen we use EXTBAN ~T to prevent some "bad words" from being sent to channel, it could probably also block part/quit messages containing those words.
Some users find that they're unable to send those words to the channel (spam, insults, swearing, etc) and they use them in the part/quit message to achieve the their goal.
IMHO, this would be a good enhancement and very helpful for channel owners, if we think in channels where different languages are spoken at the same time and network admins wouldn't need to add every single word to a spamfilter, e.g
TagsNo tags attached.
3rd party modules

Activities

Koragg

2019-06-29 23:00

reporter   ~0020748

A solid addition for sure. How EXTBAN ~T likely does it is hooking into PRIVMSG and NOTICE to intercept "bad words" so it should also be possible to extend that same behaviour to PART and QUIT as well.

syzop

2019-07-01 17:45

administrator   ~0020757

Yes this is a good idea, and we already did it in UnrealIRCd 5 ;)

(2 weeks ago, but you couldn't know, of course, since it's still in closed development for now)

Issue History

Date Modified Username Field Change
2019-06-29 22:55 The_Myth New Issue
2019-06-29 23:00 Koragg Note Added: 0020748
2019-07-01 17:45 syzop Assigned To => syzop
2019-07-01 17:45 syzop Status new => resolved
2019-07-01 17:45 syzop Resolution open => fixed
2019-07-01 17:45 syzop Fixed in Version => 5.0.0-alpha1
2019-07-01 17:45 syzop Note Added: 0020757