View Issue Details

IDProjectCategoryView StatusLast Update
0005327unrealircdpublic2019-07-07 16:14
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.2.4 
Target Version4.2.4.1Fixed in Version4.2.4.1 
Summary0005327: unknown directive set::ssl::outdated-protocols
Description06:24 < HeXiLeD> unknown directive set::ssl::outdated-protocols ?
07:47 < HeXiLeD> so where exactly outdated-protocols and outdated-ciphers go? I added it inside set block -> ssl and i get unknown directive

Seems these configuration items are never read from the config, there's no code for it.
TagsNo tags attached.
3rd party modules

Activities

syzop

2019-07-07 10:43

administrator   ~0020759

I will fix this and then release a 4.2.4.1 which includes this half-related fix https://github.com/unrealircd/unrealircd/commit/755ef5b052c3bf48ae8cc162ee254b169ab26fb0

syzop

2019-07-07 16:14

administrator   ~0020760

Fixed in https://github.com/unrealircd/unrealircd/commit/96ee7083c8442b21ee775b559fb27b352dd1d8fe, which has been released as 4.2.4.1. Thanks for the report!

commit 96ee7083c8442b21ee775b559fb27b352dd1d8fe
Author: Bram Matthys <syzop@vulnscan.org>
Date: Sun Jul 7 14:57:15 2019 +0200

    Customizing set::ssl::outdated-protocols and set::ssl::outdated-ciphers
    was not possible since the configuration code was missing.
    Reported by HeXiLeD in https://bugs.unrealircd.org/view.php?id=5327

Issue History

Date Modified Username Field Change
2019-07-03 09:41 syzop New Issue
2019-07-07 10:43 syzop Note Added: 0020759
2019-07-07 10:43 syzop Assigned To => syzop
2019-07-07 10:43 syzop Status new => confirmed
2019-07-07 16:14 syzop Status confirmed => resolved
2019-07-07 16:14 syzop Resolution open => fixed
2019-07-07 16:14 syzop Fixed in Version => 4.2.4.1
2019-07-07 16:14 syzop Note Added: 0020760