View Issue Details

IDProjectCategoryView StatusLast Update
0005343unrealircdpublic2019-09-06 15:21
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version5.0.0-alpha2 
Summary0005343: U5: update hooks with messagetags
Descriptionsome or all hooks could or would need an update so messagetags can be passed
TagsNo tags attached.
3rd party modules

Relationships

child of 0005279 acknowledged UnrealIRCd 5 master tracking issue 

Activities

syzop

2019-09-06 14:32

administrator   ~0020872

Last edited: 2019-09-06 14:33

View 2 revisions

Done in https://github.com/unrealircd/unrealircd/commit/cf873d826a8d85279ba6e1b0a663ac6093aa3125 :

commit cf873d826a8d85279ba6e1b0a663ac6093aa3125 (HEAD -> unreal50, origin/unreal50)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Fri Sep 6 14:30:16 2019 +0200

    Add MessageTag *mtags argument to various (channel related) hooks, in case
    they need access to those. For more information, see:
    https://bugs.unrealircd.org/view.php?id=5343

Only nickchange was not really feasible at this point. It may be doable after the <U4 protocol cleanup, though.

Oh, and I did not add it in the pre hooks (except some that were already there like chanmsg), since at PRE stage there is no mtag generated yet.

syzop

2019-09-06 15:21

administrator   ~0020873

I think this is sufficiently addressed.

Issue History

Date Modified Username Field Change
2019-08-10 11:26 syzop New Issue
2019-08-10 11:26 syzop Relationship added child of 0005279
2019-08-10 11:26 syzop Status new => acknowledged
2019-08-18 15:17 syzop View Status private => public
2019-09-06 14:32 syzop Note Added: 0020872
2019-09-06 14:33 syzop Note Edited: 0020872 View Revisions
2019-09-06 15:21 syzop Assigned To => syzop
2019-09-06 15:21 syzop Status acknowledged => resolved
2019-09-06 15:21 syzop Resolution open => fixed
2019-09-06 15:21 syzop Fixed in Version => 5.0.0-alpha2
2019-09-06 15:21 syzop Note Added: 0020873