View Issue Details

IDProjectCategoryView StatusLast Update
0005353unrealircdpublic2019-10-19 17:01
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version5.0.0-alpha1 
Target VersionFixed in Version5.0.0-beta1 
Summary0005353: U5: consider removing old protocol code (3.2.x etc)
Description'i' suggested we should remove all 3.2.x compatibility code in 5.x. I have not decided yet.

I don't care about linking UnrealIRCd 3.2.x to 5.x, but I do care about services. Then again, they must be quite old if they don't support UID and stuff?

I'll set the bug report to 'feedback' so other users/admins can chime in.
TagsNo tags attached.
3rd party modules

Activities

syzop

2019-08-25 14:58

administrator   ~0020848

I guess we should take a look at the services packages that are in use on U4, to see what PROTOCTL they negotiate, and with what we can get away with wrt dropping support.

syzop

2019-08-25 14:58

administrator   ~0020849

Last edited: 2019-08-25 15:09

View 4 revisions

anope 2.0.6 with "unreal4" module (not "unreal"!!):
PROTOCTL NICKv2 VHP UMODE2 NICKIP SJOIN SJOIN2 SJ3 NOQUIT TKLEXT MLOCK SID
PROTOCTL EAUTH=services.test.net,,,Anope-2.0.6
PROTOCTL SID=00B

atheme (some version from early 2019?):
sts("PROTOCTL NICKv2 VHP NICKIP UMODE2 SJOIN SJOIN2 SJ3 NOQUIT TKLEXT ESVID MLOCK");
sts("PROTOCTL SID=%s", me.numeric);


syzop

2019-08-25 15:42

administrator   ~0020850

Last edited: 2019-08-25 15:46

View 3 revisions

I pulled data from my IRCStats project. 515 networks (not servers, networks) run a services package on UnrealIRCd 4. This is based off the Dec 2018 sample.
I am deliberately leaving networks running 3.2.x out of it, since I think those are beyond help... U3.2 has been deprecated since Dec 2015 and unsupported since Jan 2017.

Anope: 477 (92.6%)
Atheme: 25 (4.9%)
IRCServices: 8 (1.5%)
Xtheme: 5 (1%)
Total: 515 (100%)

Note that this only looks at "real" services packages, the ones that usually provide NickServ. It does not look at pylink/janus/etc.

Still, looks good. Anope/Atheme/Xtheme should all provide U4 support with the modern PROTOCTL options. IRCServices is deprecated and hasn't seen a release for about 10 years, so.. yeah.. those 8 networks would need to switch :D.

Oh, yeah, of the anope networks there is 1 on 1.6.x, and 27 on 1.8.x, one on 1.9.x. I am assuming these can upgrade to 2.0.x, although that could be a wrong assumption if they customized a lot. Still.. anope offers an upgrade track for them at least.

syzop

2019-10-19 17:01

administrator   ~0021048

Done. Perhaps some stuff is still here or there but by far most of it is ripped out so this issue can be closed.

I wrote the following in https://github.com/unrealircd/unrealircd/blob/unreal50/doc/RELEASE-NOTES.md :
UnrealIRCd 5 now assumes you support the following PROTOCTL options: NOQUIT EAUTH SID NICKv2 SJOIN SJ3 NICKIP TKLEXT2. If you fail to use SID or EAUTH then you will receive an error. For the other options, support is assumed, no warning or error is shown when you lack support. These are options that most, if not all, services support since UnrealIRCd 4.x so it shouldn't be a problem.
More information here: https://www.unrealircd.org/docs/FAQ#old-server-protocol

Issue History

Date Modified Username Field Change
2019-08-19 16:17 syzop New Issue
2019-08-19 16:18 syzop Status new => feedback
2019-08-25 14:58 syzop Note Added: 0020848
2019-08-25 14:58 syzop Note Added: 0020849
2019-08-25 15:00 syzop Note Edited: 0020849 View Revisions
2019-08-25 15:05 syzop Note Edited: 0020849 View Revisions
2019-08-25 15:09 syzop Note Edited: 0020849 View Revisions
2019-08-25 15:42 syzop Note Added: 0020850
2019-08-25 15:44 syzop Note Edited: 0020850 View Revisions
2019-08-25 15:46 syzop Note Edited: 0020850 View Revisions
2019-10-19 17:01 syzop Assigned To => syzop
2019-10-19 17:01 syzop Status feedback => resolved
2019-10-19 17:01 syzop Resolution open => fixed
2019-10-19 17:01 syzop Fixed in Version => 5.0.0-beta1
2019-10-19 17:01 syzop Note Added: 0021048