View Issue Details

IDProjectCategoryView StatusLast Update
0005411unrealircdpublic2021-11-10 08:33
Reportersyzop Assigned Tosyzop  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version5.0.0-alpha2 
Fixed in Version6.0.0-beta3 
Summary0005411: U6: Colors on config warning / error
DescriptionI think some color would be nice when config_error and config_warn are used.
Only to console (ANSI) and.. perhaps IRC as well (IRC colors)? Should be configurable, default is on.
Also, with regards to console, disable color if terminal does not support it (or the reverse, only enable it if we are sure it is supported)
TagsNo tags attached.
3rd party modules

Activities

syzop

2020-04-13 08:58

administrator   ~0021463

Let's reassign this to U6.

syzop

2021-11-01 10:37

administrator   ~0022143

Done in U6. Only thing left, and the reason to keep this open for now, is an option to disable this.

syzop

2021-11-10 08:33

administrator   ~0022179

commit d74ab4cfb18cc26564ffeba1dfa7120669abe9d7 (HEAD -> unreal60_dev, origin/unreal60_dev)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Wed Nov 10 08:22:00 2021 +0100

    Add set::server-notice-colors and oper::server-notice-colors so one
    can turn colors in snomask server notices on or off.

Issue History

Date Modified Username Field Change
2019-09-18 09:22 syzop New Issue
2019-09-21 18:49 syzop Target Version 5.0.0-alpha3 => 5.0.0-alpha4
2020-04-13 08:58 syzop Target Version 5.0.0-alpha4 =>
2020-04-13 08:58 syzop Summary Colors on config warning / error => U6: Colors on config warning / error
2020-04-13 08:58 syzop Note Added: 0021463
2021-11-01 10:37 syzop View Status private => public
2021-11-01 10:37 syzop Note Added: 0022143
2021-11-10 08:33 syzop Assigned To => syzop
2021-11-10 08:33 syzop Status new => resolved
2021-11-10 08:33 syzop Resolution open => fixed
2021-11-10 08:33 syzop Fixed in Version => 6.0.0-beta3
2021-11-10 08:33 syzop Note Added: 0022179