View Issue Details

IDProjectCategoryView StatusLast Update
0005454unrealircdpublic2019-10-26 19:19
ReporterThe_MythAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSUbuntuOS Version18.04 LTS
Product Version5.0.0-alpha4 
Target VersionFixed in Version5.0.0-beta1 
Summary0005454: Idle time on /WHOIS is set to 1970-01-01 00:00:00 UTC after a connect/reconnect
DescriptionWhen a user connect to the network but hasn't send any messge yet, doing `/WHOIS nick nick` leads to the idle time being displayed as from idling since 1970-01-01 00:00:00 UTC

Steps To Reproduce- Connect to te network
- /WHOIS yourself
- Idle time will be counted since 1970-01-01 00:00:00 UTC
Additional Information# WHOIS output #

# /WHOIS right after connection #

[15:40:43] * [Whois] vitor is vitor!~vitor@C2B56B63.89805011.4C6CC189.IP (realname)
[15:40:43] * [Whois] vitor is using modes +iwxz
[15:40:43] * [Whois] vitor is a user on channels: #Chat
[15:40:43] * [Whois] vitor is using a Secure Connection
[15:40:43] * [Whois] vitor is using an IP with a reputation score of 69
[15:40:43] * [Whois] vitor is logged in since 2019-10-20 13:40:02 UTC
[15:40:43] * [Whois] vitor is idling for 49 year, 304 day, 13 h, 40 min, 43 sec (since 1970-01-01 00:00:00 UTC)
[15:40:43] * [Whois] End of /WHOIS list


# /WHOIS after sending a message to a channel #

[15:40:55] * [Whois] vitor is vitor!~vitor@C2B56B63.89805011.4C6CC189.IP (realname)
[15:40:55] * [Whois] vitor is using modes +iwxz
[15:40:55] * [Whois] vitor is a user on channels: #Chat
[15:40:55] * [Whois] vitor is using a Secure Connection
[15:40:55] * [Whois] vitor is using an IP with a reputation score of 69
[15:40:55] * [Whois] vitor is logged in since 2019-10-20 13:40:02 UTC
[15:40:55] * [Whois] vitor is idling for 3 sec (since 2019-10-20 13:40:52 UTC)
[15:40:55] * [Whois] End of /WHOIS list
TagsNo tags attached.
3rd party modules

Activities

syzop

2019-10-26 19:19

administrator   ~0021050

commit 5d7bd995fa236b898131bc968b511850c7f5e7ee (HEAD -> unreal50)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Sat Oct 26 19:18:24 2019 +0200

    Show correct idle time when a fresh user connects.
    Reported by The_Myth in https://bugs.unrealircd.org/view.php?id=5454

Issue History

Date Modified Username Field Change
2019-10-20 15:55 The_Myth New Issue
2019-10-26 19:19 syzop Assigned To => syzop
2019-10-26 19:19 syzop Status new => resolved
2019-10-26 19:19 syzop Resolution open => fixed
2019-10-26 19:19 syzop Fixed in Version => 5.0.0-beta1
2019-10-26 19:19 syzop Note Added: 0021050