View Issue Details

IDProjectCategoryView StatusLast Update
0005483unrealircdpublic2019-12-06 08:34
ReporterKoragg Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0.0-rc2 
Fixed in Version5.0.0 
Summary0005483: CAP LIST does not give any capabilities at all on IRCv3 capable IRC clients
DescriptionWhen running /CAP LIST on an UnrealIRCd 5.0.0-rc2 network, the list of given caps is empty: IMPORTANT: The string itself is NOT empty, "just" the capabilities the client requested are not displayed. This occurs on IRC clients that definietely have IRCv3 capabilities support, such as mIRC, IRCCloud and HexChat.
Steps To Reproduce1. Connect to an UnrealIRCd 5.0.0-rc2 network with an IRCv3 capable client (HexChat, mIRC, IRCCloud, etc)
2. Run /CAP LIST and observe how the text is simply [22:44] CAP LIST (how it appears on mIRC) or 23:12:36 CAP Enabled: (how it appears on IRCCloud).

Expected result: /CAP LIST shows all CAPs the client has requested and the server supports/gave an ACK for
Additional InformationThis appears to be specifically affecting U5 and as it is not tested if CAPs are set but seem to be (e.g. SASL auth works as intended) this issue is set to minor.
TagsNo tags attached.
3rd party modules

Activities

syzop

2019-12-06 08:34

administrator   ~0021139

Fixed, thanks!

commit 0bbb935a32a68ef71f6a51c035bb2c8f22bdb5fb (HEAD -> unreal50, origin/unreal50)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Fri Dec 6 08:32:36 2019 +0100

    Rename CHECKPROTO() to CHECKSERVERPROTO() to avoid mixing up server caps
    and client caps in the future.

commit a0b052655605946f19bec75175aec564ee55e17c
Author: Bram Matthys <syzop@vulnscan.org>
Date: Fri Dec 6 08:29:53 2019 +0100

    CAP LIST wasn't outputting anything. Reported by Koragg in
    https://bugs.unrealircd.org/view.php?id=5483

Issue History

Date Modified Username Field Change
2019-12-05 23:19 Koragg New Issue
2019-12-06 08:34 syzop Assigned To => syzop
2019-12-06 08:34 syzop Status new => resolved
2019-12-06 08:34 syzop Resolution open => fixed
2019-12-06 08:34 syzop Fixed in Version => 5.0.0
2019-12-06 08:34 syzop Note Added: 0021139