View Issue Details

IDProjectCategoryView StatusLast Update
0005520unrealircdpublic2020-01-20 15:36
ReporterPeGaSuS Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformUnixOSUbuntu 
Product Version5.0.0 
Summary0005520: Problems with /WHO command
DescriptionI've found some weird behavior with the /WHO command when trying to look for network opers. I have some networks linked to my network with PyLink (similar to the old Janus) and I have PyLink U-Lined.

Command used:
/WHO o m

Behaviors found:
1) As an oper, the command listed me ALL the opers, including remote networks opers, while the command /ircops only show the network opers.

2) As a normal user, the command listed only the network opers sharing a common channel or if they're not +i.

3) As a normal user, outside of any channel, the command didn't listed any oper since every user in my network gets +i by default.

Expected behavior:
Regarding 1, the command should list only the network opers, like the /ircops command.

Regarding 2 and 3, the command should list all network opers, regardless if they're sharing a common channel or if they have umode +i
Additional InformationJobe was able to reproduce at least the behaviors 2 and 3, which means that's not a problem with 3rd party modules.
TagsNo tags attached.
3rd party modulesthird/block_masshighlight, third/autovhost, third/noghosts, third/banfix_voice, third/chansno

Activities

syzop

2020-01-02 16:28

administrator   ~0021190

I think the +i rule should still be obeyed by WHO. It would be unexpected to most people if you could gather a list of online ircops that way.
Of course, if you load the module that provides the /IRCOPS command, then it is only logical that those people are listed. Then you asked for it.

I did not entirely understand your issue 1), maybe there is a typo somewhere? You use the term 'remote network opers' and 'network opers'

syzop

2020-01-20 15:36

administrator   ~0021234

We don't expose opers with "WHO o m" if they are invisible and not in a common chan, that is correct. I think we should value that privacy.
And yeah, of course /IRCOPS does show them, since that is the whole purpose of that module. If you load that module then you know what you are doing.
(You can see how this contrasts with WHO, which would come to a surprise to ircops if it would show ircops "via some special WHO command" that would otherwise be invisible)

Issue History

Date Modified Username Field Change
2020-01-02 13:08 PeGaSuS New Issue
2020-01-02 16:28 syzop Note Added: 0021190
2020-01-02 16:29 syzop Assigned To => syzop
2020-01-02 16:29 syzop Status new => feedback
2020-01-20 15:36 syzop Status feedback => closed
2020-01-20 15:36 syzop Resolution open => no change required
2020-01-20 15:36 syzop Note Added: 0021234