View Issue Details

IDProjectCategoryView StatusLast Update
0005524unrealircdpublic2020-01-09 18:35
ReporterLesterClayton Assigned Tosyzop  
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version19.10
Product Version5.0.1 
Fixed in Version5.0.2 
Summary0005524: Except Throttle does not work on 5.0.1
DescriptionThe block "Except Throttle" as described in does not function under 5.0.1, but did on 4.x
Steps To Reproduce1) Use the default set::anti-flood::connect-flood to 3:60
2) Add an except throttle for your client IP
3) Attempt more than 3 connections
Additional InformationI have tried using the following two blocks, both fail to exempt my throttling.

except throttle {
        mask *@;

except throttle {

I can also confirm that my allow block allows enough clients for my IP.

allow {
        ip *@;
        class clients;
        maxperip 500;
Tagsexcept throttle
3rd party modules



2020-01-09 17:50

reporter   ~0021207

Also wanted to add that changing set::anti-flood::connect-flood to something like 60:60 overcomes the described issue, so we can be sure that it's this setting.


2020-01-09 18:29

administrator   ~0021208

Thanks for the report, I have fixed it now in git. I made a mistake in this compatibility code.
See the commit below, and also there is mentioned an alternative which you can use that does work in the meantime, so you can use 5.0.1 :)

commit d4826bd5c02a6d37499f861e4645c9f9468f0798 (HEAD -> unreal50, origin/unreal50)
Author: Bram Matthys <>
Date: Thu Jan 9 18:23:27 2020 +0100

    except throttle { } was not working, reported by LesterClayton in
    On a side note, the new method did work OK:
    except ban { mask; type connect-flood; }

Issue History

Date Modified Username Field Change
2020-01-09 17:43 LesterClayton New Issue
2020-01-09 17:43 LesterClayton Tag Attached: except throttle
2020-01-09 17:50 LesterClayton Note Added: 0021207
2020-01-09 18:29 syzop Note Added: 0021208
2020-01-09 18:35 syzop Assigned To => syzop
2020-01-09 18:35 syzop Status new => resolved
2020-01-09 18:35 syzop Resolution open => fixed
2020-01-09 18:35 syzop Fixed in Version => 5.0.2