View Issue Details

IDProjectCategoryView StatusLast Update
0005536unrealircdpublic2020-01-20 15:24
Reporterk4beAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionnot fixable 
Product Version5.0.1 
Target VersionFixed in Version 
Summary0005536: Multiple notices caused by /KNOCK
DescriptionThe notice about knocking now comes from multiple servers at once (both u4 and u5).
09:30 !netsplit.pirc.pl [Knock] by testtesttesttest!pirc@DC5C712E:818D0E0A:A8964103:IP (message)
09:30 !legowisko.pirc.pl [Knock] by testtesttesttest!pirc@DC5C712E:818D0E0A:A8964103:IP (message)
09:30 !bzyk.pirc.pl [Knock] by testtesttesttest!pirc@DC5C712E:818D0E0A:A8964103:IP (message)
09:30 !hub2.pirc.pl [Knock] by testtesttesttest!pirc@DC5C712E:818D0E0A:A8964103:IP (message)
Steps To Reproduce/KNOCK #somechannel somemessage
TagsNo tags attached.
3rd party modules

Activities

syzop

2020-01-20 14:02

administrator   ~0021228

It is probably because of this:
    Update KNOCK to be sent across servers. This will cause double notices
    if you are running a mixed U4 and U5 network, but it solves the situation
    where a knock-flood is only detected locally. Since KNOCK usage isn't
    that common and flooding is worse than double notices during the
    transition period, I went with this change..

Can you verify that this is indeed only if the channel operator is connected to an UnrealIRCd 4 server on an UnrealIRCd 5 network?

syzop

2020-01-20 14:04

administrator   ~0021229

Last edited: 2020-01-20 14:04

View 2 revisions

For what it's worth I tried to duplicate it on an A-B-C server setup and I always get 1 notice, regardless of which server (A, B or C) the user is knocking on and regardless on which server the chanop is (A, B or C).
So I'm pretty confident it is just that :)
The only thing wrong is that my comment is incorrect in the sense that it isn't just a "double notice" but a lot more, which obviously is even more annoying to the chanops :)

k4be

2020-01-20 14:20

reporter   ~0021230

Knocking side (connected to insomnia -> U5):
14:16 !insomnia.pirc.pl Knocked on #testtest
14:16 !legowisko.pirc.pl Knocked on #testtest
14:16 !hub2.pirc.pl Knocked on #testtest

Chanop side (connected to netsplit -> U5):
14:16 !netsplit.pirc.pl [Knock] by testtest!~k4be@ukryty-7FA62A4F.neoplus.adsl.tpnet.pl (no reason specified)
14:16 !legowisko.pirc.pl [Knock] by testtest!~k4be@ukryty-7FA62A4F.neoplus.adsl.tpnet.pl (no reason specified)
14:16 !hub2.pirc.pl [Knock] by testtest!~k4be@ukryty-7FA62A4F.neoplus.adsl.tpnet.pl (no reason specified)

There are no more users on this channel.
Servers "legowisko" and "hub2" are out of the message path, and are the only 4.x ones. Apparently only the 4.x servers are sending the extra notices, so nothing can be really done with that.

syzop

2020-01-20 15:21

administrator   ~0021231

Ah ok, so every 4.x results in an echo... so to say. Fun! Yeah nothing can be done about that.

Issue History

Date Modified Username Field Change
2020-01-19 09:38 k4be New Issue
2020-01-20 14:02 syzop Note Added: 0021228
2020-01-20 14:02 syzop Assigned To => syzop
2020-01-20 14:02 syzop Status new => feedback
2020-01-20 14:02 syzop Priority high => normal
2020-01-20 14:04 syzop Note Added: 0021229
2020-01-20 14:04 syzop Note Edited: 0021229 View Revisions
2020-01-20 14:20 k4be Note Added: 0021230
2020-01-20 15:21 syzop Note Added: 0021231
2020-01-20 15:24 syzop Status feedback => closed
2020-01-20 15:24 syzop Resolution open => not fixable