View Issue Details

IDProjectCategoryView StatusLast Update
0005538unrealircdpublic2020-01-26 09:56
Reporterk4be Assigned Tosyzop  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionno change required 
Product Version5.0.1 
Summary0005538: Inconsistent format of WHOIS 311 reply
DescriptionThe format changes when the reply is coming through from different server - last argument is missing the starting ":" character. Some clients may have problems handling this (as i had to tweak mine for it).

whois nick
:localserver.example.com 311 test nick ident host * :realname

whois nick nick
:remoteserver.example.com 311 test nick ident host * realname
TagsNo tags attached.
3rd party modules

Activities

syzop

2020-01-26 09:56

administrator   ~0021260

I have not fixed this bug because I don't believe it is a bug. I have however fixed something very related. So thanks for the report. See the changelog below:

commit c9feaa0b1538026669d9f2105300df38dfea4ee3 (HEAD -> unreal50, origin/unreal50)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Sun Jan 26 09:46:59 2020 +0100

    Fix : at beginning of gecos being dropped off in intra-WHOIS.
    
    This does NOT "fix" https://bugs.unrealircd.org/view.php?id=5538:
    WHOIS nick
    :localserver.example.com 311 test nick ident host * :realname
    WHOIS nick nick
    :remoteserver.example.com 311 test nick ident host * realname
    .. because your IRC protocol parser should not care about a :
    or a lack of :. For text not containing spaces nor :-prefix there
    is no difference in meaning and it should parse to the same.
    
    However, this DOES fix an issue if the realname itself started
    with a colon, such as "USER x x x ::something":
    WHOIS nick
    :localserver.example.com 311 test nick ident host * ::something
    WHOIS nick nick
    :remoteserver.example.com 311 test nick ident host * :something
    .. because that does not have the same meaning and is a real
    incorrect drop of a character.
    Yeah, I took into account spaces, but not a word starting with :, my bad.

Issue History

Date Modified Username Field Change
2020-01-22 07:31 k4be New Issue
2020-01-26 09:56 syzop Assigned To => syzop
2020-01-26 09:56 syzop Status new => closed
2020-01-26 09:56 syzop Resolution open => no change required
2020-01-26 09:56 syzop Note Added: 0021260