View Issue Details

IDProjectCategoryView StatusLast Update
0005554unrealircdpublic2020-02-11 17:46
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version5.0.3 
Target VersionFixed in Version5.0.3.1 
Summary0005554: Crash reporter often not running?
DescriptionI have the feeling that the crash reporter is often not kicking in on 5.x. Or, unrealircd is just incredibly stable, that is possible as well :D :D
TagsNo tags attached.
3rd party modules

Activities

syzop

2020-02-11 17:42

administrator   ~0021303

Ah, duh:
Breakpoint 1, find_best_coredump () at crashreport.c:28
28 {
(gdb) n
33 DIR *fd = opendir(TMPDIR);
(gdb)
35 if (!fd)
(gdb)
38 *best_fname = '\0';
(gdb)
40 while ((dir = readdir(fd)))
(gdb)
42 char *fname = dir->d_name;
(gdb)
43 if (filename_has_suffix(fname, ".core"))
(gdb)

On many systems the coredump is just "core" (tmp/core), without the dot.

Means we are missing quite some crashes though

syzop

2020-02-11 17:46

administrator   ~0021304

commit f585e895a2125ca53c1576789236177a551ab013 (HEAD -> unreal50)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Tue Feb 11 17:44:59 2020 +0100

    Crash reporter: was missing many crashes due to search for core
    files that end in .core, while on many systems it is just 'core'
    without the dot. Reverted back to U4-style core file finding now.
    Thanks to DeviL for helping to trace this issue.

Issue History

Date Modified Username Field Change
2020-02-10 19:04 syzop New Issue
2020-02-10 19:04 syzop Assigned To => syzop
2020-02-10 19:04 syzop Status new => acknowledged
2020-02-11 17:42 syzop Note Added: 0021303
2020-02-11 17:46 syzop Status acknowledged => resolved
2020-02-11 17:46 syzop Resolution open => fixed
2020-02-11 17:46 syzop Fixed in Version => 5.0.3.1
2020-02-11 17:46 syzop Note Added: 0021304