View Issue Details

IDProjectCategoryView StatusLast Update
0005629unrealircdpublic2020-04-17 09:32
Reporterk4be Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0.3.1 
Fixed in Version5.0.4 
Summary0005629: Incorrect user shown removing glines, gzlines and spamfilters on remote server
DescriptionExample:
Oper X connected to server A sets a gzline.
Oper Y connected to server B removes this gzline.
All opers connected to B see that oper Y removed the gzline - correct.
All opers connected to servers other than B see that oper X (the original setter) removed the gzline - incorrect.
TagsNo tags attached.
3rd party modules

Activities

syzop

2020-04-17 09:32

administrator   ~0021499

Fixed in 5.0.4. Although I should probably do a better fix post-release, just wanted to keep it minimal due to it being post-release-candidate. Bug can be closed though. Thanks for the report.

commit 49d595f60c3f284f9b86a042c96e6bda9e9122ce (HEAD -> unreal50)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Fri Apr 17 09:27:16 2020 +0200

    On *LINE removal it showed the wrong person in the notice sent to IRCOps
    (on remote servers). It showed the originally setter and not the remover.
    Reported by k4be in https://bugs.unrealircd.org/view.php?id=5629

Issue History

Date Modified Username Field Change
2020-04-16 17:51 k4be New Issue
2020-04-17 09:32 syzop Assigned To => syzop
2020-04-17 09:32 syzop Status new => resolved
2020-04-17 09:32 syzop Resolution open => fixed
2020-04-17 09:32 syzop Fixed in Version => 5.0.4
2020-04-17 09:32 syzop Note Added: 0021499