View Issue Details

IDProjectCategoryView StatusLast Update
0005695unrealircdpublic2020-09-27 19:55
Reporterk4be Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version5.0.5 
Summary0005695: echo-message is not working with service aliases
DescriptionThese aliases are meant as a replacement for PRIVMSGs so the message should be echoed even though it is not PRIVMSG by itself.

CAP REQ :echo-message
:bzyk.pirc.pl CAP testtest ACK :echo-message
PRIVMSG ChanServ :test
:testtest!~a@AF44EF2A:A0AB0173:2D93A6A7:IP PRIVMSG ChanServ :test
:ChanServ!ChanServ@serwisy.pirc.pl NOTICE testtest :Nieznana komenda test. Napisz "/msg ChanServ HELP" aby uzyskac pomoc.
CS test
:ChanServ!ChanServ@serwisy.pirc.pl NOTICE testtest :Nieznana komenda test. Napisz "/msg ChanServ HELP" aby uzyskac pomoc.
TagsNo tags attached.
3rd party modules

Activities

syzop

2020-09-27 19:55

administrator   ~0021771

Seemingly this idea is not really backed by IRCv3, although it's not conclusive.
Personally I think it's a bit weird to start echo'ing back on commands, since the client will have no idea if it is like a real server command or an alias. So I would be afraid of client issues.

Issue History

Date Modified Username Field Change
2020-05-31 21:24 k4be New Issue
2020-09-27 19:55 syzop Assigned To => syzop
2020-09-27 19:55 syzop Status new => closed
2020-09-27 19:55 syzop Resolution open => no change required
2020-09-27 19:55 syzop Note Added: 0021771