View Issue Details

IDProjectCategoryView StatusLast Update
0005709unrealircdpublic2020-07-14 19:33
Reporterk4be Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0.5.1 
Fixed in Version5.0.6 
Summary0005709: Invalid batch tags when using @label-ed HISTORY command
DescriptionI'm not sure how this should work, but certainly there shouldn't be multiple `batch` tag key values (the third reply or fourth line).
← @label=xxx history #testtest
→ @label=xxx :test3.pirc.pl BATCH +PbZCD0QZGMMHQwa7KU5Y4V labeled-response
→ @batch=PbZCD0QZGMMHQwa7KU5Y4V :test3.pirc.pl BATCH +2CrEHYl23nQnHSS4KOolGT chathistory #testtest
→ @batch=PbZCD0QZGMMHQwa7KU5Y4V;batch=2CrEHYl23nQnHSS4KOolGT;time=2020-06-12T13:56:03.465Z;msgid=i5gz6M8Qw0hWThWnCyJQFa :k4be!testowy@127.0.0.1 PRIVMSG #testtest :7
→ @batch=2CrEHYl23nQnHSS4KOolGT;time=2020-06-12T13:56:05.306Z;msgid=n9AFDtvL1QSpclJltL9WX9 :k4be!testowy@127.0.0.1 PRIVMSG #testtest :8
→ @batch=2CrEHYl23nQnHSS4KOolGT;time=2020-06-12T13:56:07.204Z;msgid=mvIN1kI7vzGbFSNhPFpsIU :k4be!testowy@127.0.0.1 PRIVMSG #testtest :9
[CUT]
→ @batch=2CrEHYl23nQnHSS4KOolGT;time=2020-06-12T13:57:03.058Z;msgid=hB4gDSv82uoLYgbLXcqZkq :k4be!testowy@127.0.0.1 PRIVMSG #testtest :y
→ @batch=2CrEHYl23nQnHSS4KOolGT;time=2020-06-12T13:57:05.062Z;msgid=UbcH5fYYaJV2qpQORjuxCe :k4be!testowy@127.0.0.1 PRIVMSG #testtest :z
→ @batch=PbZCD0QZGMMHQwa7KU5Y4V :test3.pirc.pl BATCH -2CrEHYl23nQnHSS4KOolGT
→ :test3.pirc.pl BATCH -PbZCD0QZGMMHQwa7KU5Y4V
Steps To ReproduceCreate a channel, set +H and store some history entries. Then do:
cap req :labeled-response batch server-time message-tags
@label=xxx history #testtest
TagsNo tags attached.
3rd party modules

Activities

syzop

2020-06-12 17:59

administrator   ~0021629

Last edited: 2020-06-12 18:00

View 4 revisions

It should have removed the other batch tag, so:
@batch=PbZCD0QZGMMHQwa7KU5Y4V;batch=2CrEHYl23nQnHSS4KOolGT;...

Should have become:
@batch=2CrEHYl23nQnHSS4KOolGT;...

Probably not so hard to fix.

syzop

2020-07-14 19:33

administrator   ~0021664

Fixed, thanks for the report.. seems it only showed up with the HISTORY command and not in history on join, so I didn't notice it before...

Issue History

Date Modified Username Field Change
2020-06-12 17:57 k4be New Issue
2020-06-12 17:59 syzop Note Added: 0021629
2020-06-12 17:59 syzop Status new => acknowledged
2020-06-12 18:00 syzop Note Edited: 0021629 View Revisions
2020-06-12 18:00 syzop Note Edited: 0021629 View Revisions
2020-06-12 18:00 syzop Note Edited: 0021629 View Revisions
2020-07-14 19:33 syzop Assigned To => syzop
2020-07-14 19:33 syzop Status acknowledged => resolved
2020-07-14 19:33 syzop Resolution open => fixed
2020-07-14 19:33 syzop Fixed in Version => 5.0.6
2020-07-14 19:33 syzop Note Added: 0021664