View Issue Details

IDProjectCategoryView StatusLast Update
0005726unrealircdpublic2020-07-22 17:18
ReporterLesterClayton Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSUbuntu 
Product Version5.0.6 
Summary0005726: Chanserv no longer sets mode +r
DescriptionChanServ no longer sets mode +r for registered channels, old or new.
Steps To ReproduceJoin unowned channel
register channel with Chanserv
Chanserv bot auto-joins, but channel mode is not set to +r any more
Additional InformationServices is Atheme 7.2.10-r2 with Unreal4 module
Network contains 3 linked servers plus services
No change to configuration was done at either UnrealIRCD or Services, the only change was upgrading from 5.0.5.1 to 5.0.6
Tagsservices
3rd party modulesshowwebirc

Activities

LesterClayton

2020-07-22 12:06

reporter   ~0021669

Observation: Setting the MLOCK feature of a channel to include +r does make ChanServ set +r, but this hasn't had to be done in the past - it has been set automatically before.

Jobe

2020-07-22 12:06

reporter   ~0021670

This sounds to me like a compatibility issue with Atheme as Anope continues to be able to set channel mode +r on UnrealIRCD 5.0.6 (Tested with Anope 2.0.7 and UnrealIRCd 5.0.6 on irc.unrealircd.org)

syzop

2020-07-22 12:26

administrator   ~0021671

Tested with UnrealIRCd 5.0.6 with atheme 7.2.9. It doesn't even try to set the channel +r.

I do find this if I google, in atheme-contrib-module:
cs_regmode.c
Sets the stupid, pointless DALNet-style +/-r mode when a channel is registered or dropped. NOT RECOMMENDED TO USE.

So it seems they have some kind of hate towards +r at atheme. If you want more details, you would have to ask them I guess :D

LesterClayton

2020-07-22 15:02

reporter   ~0021672

I think I'm on crazy pills or something but I'm absolutely sure that +r was on with my old unrealircd 5.0.5.1, and it no longer did it since 5.0.6

I am going to try to lab this and see if I can get it "working" on 5.0.5.1 again and then upgrade once more.

In either case, you're right it's Services that is supposed to set this mode. According to the Atheme guys though, this should only be set if I have that contrib module loaded. I don't understand how it worked without it. I'll provide feedback :)

LesterClayton

2020-07-22 15:33

reporter   ~0021673

Apparently I was very mistaken. Chanserv must never have been setting mode +r and I've been terribly confused. I apologize for wasting peoples time. This isn't a bug at all it's operator error.

syzop

2020-07-22 17:18

administrator   ~0021674

Hehe, no problem :)

Issue History

Date Modified Username Field Change
2020-07-22 11:53 LesterClayton New Issue
2020-07-22 11:53 LesterClayton Tag Attached: services
2020-07-22 12:06 LesterClayton Note Added: 0021669
2020-07-22 12:06 Jobe Note Added: 0021670
2020-07-22 12:26 syzop Note Added: 0021671
2020-07-22 15:02 LesterClayton Note Added: 0021672
2020-07-22 15:33 LesterClayton Note Added: 0021673
2020-07-22 17:18 syzop Assigned To => syzop
2020-07-22 17:18 syzop Status new => closed
2020-07-22 17:18 syzop Resolution open => no change required
2020-07-22 17:18 syzop Note Added: 0021674