View Issue Details

IDProjectCategoryView StatusLast Update
0005730unrealircdpublic2020-09-26 12:22
ReporterDjSxX Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version5.0.5.1 
Summary0005730: Registered users bypass textban
DescriptionI would like to report that extban/textban is not working at all on version 5.0.5.1

[30-07-2020][11:20:10] * Stanley sets mode: +b ~T:block:*test*
[30-07-2020][11:20:17] <Stenly> test

Even when I unloaded and reloaded the module in its config, the ban will be bypassed
Steps To Reproducenvt
Additional Informationnvt
TagsNo tags attached.
3rd party modulesthird/operpasswd, third/signore, third/showwebirc

Activities

westor

2020-07-30 12:33

reporter   ~0021675

I cannot reproduce it, are you sure the nickname that is trying to say "test" is not a IRC Operator but a regular user?

DjSxX

2020-07-30 12:38

reporter   ~0021676

The nick Stenly is a non-ircop, he is voiced though, but even when not voiced he still can say test

PeGaSuS

2020-07-30 21:02

reporter   ~0021677

This is what happens in my network:

<PeGaSuS> I am a kamikaze
-- Mode #spamtest [+b ~T:block:*kamikaze*] by James
<~James> !op PeGaSuS
-- Mode #spamtest [+o PeGaSuS] by ChanServ
<@PeGaSuS> I am a kamikaze
<~James> !down PeGaSuS
-- Mode #spamtest [-o PeGaSuS] by ChanServ
<~James> !voice PeGaSuS
-- Mode #spamtest [+v PeGaSuS] by ChanServ
<+PeGaSuS> I am a kamikaze
<~James> !down PeGaSuS
-- Mode #spamtest [-v PeGaSuS] by ChanServ
<PeGaSuS> I am a kamikaze
-- #spamtest: Message blocked due to a text ban (#spamtest)

The user PeGaSuS at the time wasn't logged in (I've issued the /ns logout command).

If the user has op/voice it bypasses the textblock extban, otherwise the message is blocked.

Is this a bug or its like this by design?

IMHO, if a textblock extban is set, no one (except opers probably) should be able to bypass it, despite the channel status.

Cheers!

PeGaSuS

2020-07-30 21:05

reporter   ~0021678

Edit to the above note:
If the user is logged in, even without any status in the channel (normal user), the textblock extban is bypassed.

Looks like a bug :)

PeGaSuS

2020-07-30 21:07

reporter   ~0021679

Edit 2:

This happens after I identify to my main account:

[21:03:15] Mode #spamtest +qo PeGaSuS PeGaSuS by &ChanServ
[21:03:20] <~PeGaSuS> !down
[21:03:20] Mode #spamtest -oq PeGaSuS PeGaSuS by &ChanServ
[21:03:26] <PeGaSuS> I am a kamikaze

syzop

2020-08-02 14:28

administrator   ~0021687

So if the user is identified to services, he can bypass ~T:block ? Can you confirm DjSxX by checking with a registered and with an unregistered nick?
(And indeed ircop bypasses, and +vhoaq too I believe, this is normal)

DjSxX

2020-08-02 14:35

reporter   ~0021688

[02-08-2020][14:30:00] * Stanley sets mode: +b ~T:block:*test*
[02-08-2020][14:30:15] <Testert> test <-- voiced user (not logged in)
[02-08-2020][14:30:32] * TattooBot sets mode: -v Testert
[02-08-2020][14:30:35] Testert:test
 Message blocked due to a text ban (#TattooJukebox)
NickServ:Wachtwoord aanvaard - je wordt nu herkend.
[02-08-2020][14:30:42] Testert:Test <-- logged in to services

So when logged in to services, textban will be overwritten when devoiced
When not logged, +v users (logged in or not) will bypass the textban
While in U4 version of this textban even +vh users could not bypass the textban.

syzop

2020-08-02 15:06

administrator   ~0021689

I have changed the title of this bug to "Registered users bypass textban". This is a strange bug, it was not intended to let registered users bypass ~T.

As for the +v behavior, that is tracked at 0005698.

syzop

2020-08-23 19:48

administrator   ~0021716

Last edited: 2020-08-23 19:50

View 2 revisions

I cannot reproduce this issue, so I've set it back to 'feedback':

:s5667!~x@oper/netadmin.test.net MODE #test +b ~T:block:*forbidden*
PRIVMSG #test :forbidden!
:maintest.test.net 404 c5667 #test :Message blocked due to a text ban (#test)

then with +r:
:c5667 NICK :Syzop
[..]
:NickServ!services@services.host NOTICE Syzop :Password accepted - you are now recognized.
:maintest.test.net 900 Syzop Syzop!~x@localhost Syzop :You are now logged in as Syzop.
:NickServ MODE Syzop :+r
PRIVMSG #test :forbidden!
:maintest.test.net 404 Syzop #test :Message blocked due to a text ban (#test)

Any clarifications from your side (reporter or pegasus) would be appreciated. Just to be clear: the reported issue here was that a +r user without +vhoaq would bypass +b ~T:block:...

syzop

2020-08-29 15:08

administrator   ~0021728

Just to be clear, I cannot reproduce this. If nobody else can in the next couple of weeks then I will close this bug report.
Also maybe check if any 3rd party modules are loaded that may cause this?

syzop

2020-09-26 12:22

administrator   ~0021753

Closing, nobody can provide instructions or proof, even after repeated requests.

Issue History

Date Modified Username Field Change
2020-07-30 11:29 DjSxX New Issue
2020-07-30 12:33 westor Note Added: 0021675
2020-07-30 12:38 DjSxX Note Added: 0021676
2020-07-30 21:02 PeGaSuS Note Added: 0021677
2020-07-30 21:05 PeGaSuS Note Added: 0021678
2020-07-30 21:07 PeGaSuS Note Added: 0021679
2020-08-02 14:28 syzop Note Added: 0021687
2020-08-02 14:28 syzop Assigned To => syzop
2020-08-02 14:28 syzop Status new => feedback
2020-08-02 14:35 DjSxX Note Added: 0021688
2020-08-02 15:06 syzop Summary extban/textban doesn't work => Registered users bypass textban
2020-08-02 15:06 syzop Note Added: 0021689
2020-08-02 15:06 syzop Status feedback => confirmed
2020-08-23 19:48 syzop Status confirmed => feedback
2020-08-23 19:48 syzop Note Added: 0021716
2020-08-23 19:50 syzop Note Edited: 0021716 View Revisions
2020-08-29 15:08 syzop Note Added: 0021728
2020-09-26 12:22 syzop Status feedback => closed
2020-09-26 12:22 syzop Resolution open => no change required
2020-09-26 12:22 syzop Note Added: 0021753