View Issue Details

IDProjectCategoryView StatusLast Update
0005739unrealircdpublic2020-08-23 19:59
Reporterarmyn Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Summary0005739: a French Internet service provider with hostnames in "_"
DescriptionFor 5 months, the ISP has changed the hostnames by adding the character "_".

This one is not resolved on UnrealIRCd, can you accept the "_" character in the hostname resolution?

Here is an example:

[10:19:07] Adresse: o-ply-fr8d1f0f1@384440.8E73AA79.EF8C78B6.IP (18/H/fr/a:1.73)
[10:19:07] Host: *@88.124.11x.x <== Unrealircd does not solve it
[10:19:07] IP: *@88.124.11x.x


WoisPlus (in PHP):
[10:19:08] [Whois Plus] IP/Host: 88.124.11x.xx@lta31-1_migr-xx-xx-xx-xx.fbx.proxad.net (FR) <== Php solves it all the time
[10:19:08] [Whois Plus] Type d'IP: Residential/Unclassified IP (i.e. safe IP)
[10:19:08] [Whois Plus] ISP (geoip2): Free SAS
[10:19:08] [Whois Plus] Organization (geoip2): Free SAS


It's been 5 months now, and I don't have the impression that they will change



TagsNo tags attached.
3rd party modules

Activities

k4be

2020-08-10 21:53

developer   ~0021692

Not an UnrealIRCd problem. The revdns is invalid. It should match both ways.
$ host 88.124.111.11
11.111.124.88.in-addr.arpa domain name pointer dec69-6_migr-88-124-111-11.fbx.proxad.net.
$ host dec69-6_migr-88-124-111-11.fbx.proxad.net
Host dec69-6_migr-88-124-111-11.fbx.proxad.net not found: 3(NXDOMAIN)

armyn

2020-08-10 22:03

reporter   ~0021693

Ah ok, Free they have trouble fixing this

syzop

2020-08-23 19:58

administrator   ~0021718

As k4be says, the 2nd check fails, so even allowing underscore won't help then.

syzop

2020-08-23 19:59

administrator   ~0021719

You can edit src/dns.c line 300:
if (!isalnum(*p) && !strchr(".-", *p))
to:
if (!isalnum(*p) && !strchr(".-_", *p))

but as said, i doubt it will help, since reverse dns does not match forward dns, the underscore is not even the problem in this case.

Closing :)

Issue History

Date Modified Username Field Change
2020-08-10 10:30 armyn New Issue
2020-08-10 21:53 k4be Note Added: 0021692
2020-08-10 22:03 armyn Note Added: 0021693
2020-08-23 19:58 syzop Note Added: 0021718
2020-08-23 19:59 syzop Assigned To => syzop
2020-08-23 19:59 syzop Status new => closed
2020-08-23 19:59 syzop Resolution open => no change required
2020-08-23 19:59 syzop Note Added: 0021719