View Issue Details

IDProjectCategoryView StatusLast Update
0005843unrealircdpublic2021-03-27 09:19
Reporterwestor Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0.9 
Fixed in Version5.2.0-rc1 
Summary0005843: /eline ~S:CERT returns an invalid error
DescriptionHello,

I got always the following error even if i don't specify "zZcb" on /eline

Error Message:
ERROR: Ban exceptions with type z/Z/c/b do not work on extended server bans. This is because checking (g)zlines, connect-flood and blacklists is done BEFORE extended bans can be checked.

-Thanks!
Steps To Reproduce/eline ~S:b5815da86040e2fb3618fe3d4c2b2c26c8f9e54be43b40c2b91120abb49956dc kGqsFdmr8v 0 test
TagsNo tags attached.
3rd party modules

Activities

syzop

2021-03-27 09:19

administrator   ~0021927

Thanks, fixed in https://github.com/unrealircd/unrealircd/commit/d9fbb51a335082f53ec7acc92a2e46a96ffb2b04
The server is correct to reject the type because 'd' checks are also handled before a handshake are done. But, indeed, it did not mention 'd' at all in the NOTICE, only z/Z/c/b, so that was rather confusing.
We now print a better / more general error message instead, pointing to the first match that triggers the warning.

commit 0ea86fce83cf3e65ee9d00c3c0b995cbfc0841d5 (HEAD -> unreal50, origin/unreal50)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Sat Mar 27 09:11:15 2021 +0100

    Forbid using extended server bans in ZLINE/GZLINE as they only work on *@IP.
    ...and give a hint to use KLINE/GLINE instead.

commit d9fbb51a335082f53ec7acc92a2e46a96ffb2b04
Author: Bram Matthys <syzop@vulnscan.org>
Date: Sat Mar 27 09:09:26 2021 +0100

    Fix error message for /ELINE not working with certain types.
    Reported by westor in https://bugs.unrealircd.org/view.php?id=5843
    
    This makes the code more generic so it's just adding a 1/0 in
    the TKL types table.

Issue History

Date Modified Username Field Change
2021-03-27 03:14 westor New Issue
2021-03-27 09:19 syzop Assigned To => syzop
2021-03-27 09:19 syzop Status new => resolved
2021-03-27 09:19 syzop Resolution open => fixed
2021-03-27 09:19 syzop Fixed in Version => 5.2.0-rc1
2021-03-27 09:19 syzop Note Added: 0021927