View Issue Details

IDProjectCategoryView StatusLast Update
0005899unrealircdpublic2021-06-02 15:32
ReporterPeGaSuS Assigned Tosyzop  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSUbuntuOS Version20.04
Product Version5.0.9 
Fixed in Version5.2.0-rc1 
Summary0005899: UnrealIRCd fails to compile when enabling remote includes if libcurl4-openssl-dev isn't installed
DescriptionThe issue affects the stable and git versions.

Logs available at:

https://gist.github.com/PeGaSuS-Coder/4c4a0772f98e4c834b16156eaaffc5b9
Steps To ReproduceJust try to enable remote includes on a system without libcurl4-openssl-dev
Additional InformationcURL configure stops with:

configure: error: select TLS backend(s) or disable TLS with --without-ssl.

Select from these:

  --with-amissl
  --with-bearssl
  --with-gnutls
  --with-mbedtls
  --with-mesalink
  --with-nss
  --with-openssl (also works for BoringSSL and libressl)
  --with-rustls
  --with-schannel
  --with-secure-transport
  --with-wolfssl
TagsNo tags attached.
3rd party modules

Activities

syzop

2021-06-02 14:36

administrator   ~0021988

Right, so ./Config calls the extras/curlinstall script, which fetched cURL from our UnrealIRCd servers. The issue is that latest cURL (7.77.0) requires you to explicitly choose which TLS engine to use.
I've temporarily downgraded the .tar.gz on the UnrealIRCd site to 7.76.1. This fixes the issue for all existing users.

In addition to that, I have added code to UnrealIRCd in git so that we can use 7.77.0 and later again. So after next release (+ maybe some time) we can let everyone use latest cURL again.
https://github.com/unrealircd/unrealircd/commit/d9b80d889fcb4f051f580cc3601c80e608796dfa

syzop

2021-06-02 15:32

administrator   ~0021989

Sorry I just realized I forgot to thank you not just here but also in the git commit :p (and reference this bugid)
Thanks for the report :D

Issue History

Date Modified Username Field Change
2021-05-31 18:51 PeGaSuS New Issue
2021-06-02 14:31 syzop Additional Information Updated View Revisions
2021-06-02 14:36 syzop Note Added: 0021988
2021-06-02 14:36 syzop Assigned To => syzop
2021-06-02 14:36 syzop Status new => resolved
2021-06-02 14:36 syzop Resolution open => fixed
2021-06-02 14:36 syzop Fixed in Version => 5.2.0-rc1
2021-06-02 15:32 syzop Note Added: 0021989