View Issue Details

IDProjectCategoryView StatusLast Update
0006020unrealdocumentationpublic2021-12-08 07:19
Reporterarcanefeenix Assigned Tosyzop  
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebianOS Version11.1
Product Version6.0.0-rc2 
Fixed in Version6.0.0 
Summary0006020: snomasks.default.conf include missing from example conf
DescriptionWhen using the example config included with the package, after setting all the appropriate settings and running a configtest, you are told to include an extra line:

[info] Loading IRCd configuration..
[info] Testing IRCd configuration..
[error] Missing snomask logging configuration:
[error] Please add the following line to your unrealircd.conf: include "snomasks.default.conf";
[error] IRCd configuration failed to pass testing
[error] IRCd configuration failed to load
Steps To Reproduce- Rename conf/example/example.conf to conf/unrealircd.conf
- Change required settings
- Run server or run configtest
Additional InformationLikely due to the change where you can customize log output to snomasks.
Tagsconf
3rd party modules

Activities

syzop

2021-12-08 07:19

administrator   ~0022239

Thanks! Easy fix but important for new users :)

commit cc5f318d277996744980b077a19dfd5f2f31a4ed (HEAD -> unreal60_dev, origin/unreal60_dev)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Wed Dec 8 07:17:40 2021 +0100

    Add include for snomasks.default.conf in example.*conf
    Reported by arcanefeenix in https://bugs.unrealircd.org/view.php?id=6020

Issue History

Date Modified Username Field Change
2021-12-07 04:06 arcanefeenix New Issue
2021-12-07 04:06 arcanefeenix Tag Attached: conf
2021-12-08 07:19 syzop Assigned To => syzop
2021-12-08 07:19 syzop Status new => resolved
2021-12-08 07:19 syzop Resolution open => fixed
2021-12-08 07:19 syzop Fixed in Version => 6.0.0
2021-12-08 07:19 syzop Note Added: 0022239