View Issue Details

IDProjectCategoryView StatusLast Update
0006025unrealircdpublic2022-01-10 16:55
ReporterManuelchen Assigned Tosyzop  
Status resolvedResolutionfixed 
Product Version6.0.0 
Fixed in Version6.0.2-rc1 
Summary0006025: Windows: IRCd keeps crashing during a link
DescriptionHello, I have the problem on a Windows vServer that the IRC server is terminated immediately after a link and I have no logs whatsoever.

Why is this happening ?!
TagsNo tags attached.
3rd party modules



2021-12-18 18:39

administrator   ~0022243

Can you check if you have any *.mdmp files in your directory: C:\Program Files\UnrealIRCd 6
Or in the subfolders "bin" or "tmp" (but i think they appear in the main folder)

* If you have one of these .mdmp files, can you attach it here ? They will help me trace the issue
* And also, copy-paste or attach any unrealircd.<somenumber>.core file(s) as well, they contain textual information about the crash

I have set the bug report as 'private' so it is safe to share them here.


2021-12-18 18:44

reporter   ~0022244

Unfortunately I have nothing to pass on :(


2021-12-18 18:53

administrator   ~0022245

Ah ok, too bad :(

Then I will have try on my end to reproduce the issue tomorrow (or later).

Anything special about your link blocks? Unusual options? Etc?
Just asking so I know if I test myself.

Thanks! Will read and try tomorrow.


2021-12-18 19:10

reporter   ~0022247

Can I start the IRCd in Debug mode on Windows?


2021-12-18 19:51

reporter   ~0022249

Before I forget to mention ...
The problem is only with Unrealircd 6


2021-12-18 20:00

reporter   ~0022250

Link block and other information in the configuration is everything in original (standard)


2021-12-19 09:13

administrator   ~0022253

I'm afraid I cannot reproduce the problem here. I've linked it to U5 and to U6. I've hammered it with 1000 clients. I've hammered it with multiple concurrent outstanding linking requests squiting and (re-)linking. It remained stable here.

You asked on IRC if there is like a debug option that you can enable on your end. Answer: no, nothing on your side at the moment.
It is strange that you don't get any .core or .mdmp files. They should be created upon a crash and are really useful in helping trace any crashes.

Do you have any further information on your setup? Anything that may help us replicate the problem?
Are all servers on UnrealIRCd 6?
Does it crash every time? Or only sometimes?

Do you run in services mode or in GUI mode? If you run in services mode, could you change to GUI mode, to see if crash files (or a popup) is generated when it crashes? If you run in GUI mode already then no change needed.


2021-12-19 10:25

reporter   ~0022255

Hello, it is installed without service support.

The only problem is with Unrealircd 6.

With Unrealircd 5 everything works.

So there is definitely a bug with the linking, which brings the IRCd to an end.


2021-12-19 10:59

reporter   ~0022256

I installed Unrealircd 6 times on my PC (Windows 10), the same problem.

So I can reproduce on my PC, but Windows Server 2019 is running on the Windows vServer


2021-12-20 19:03

reporter   ~0022268

Are you still on the problem?

Because the problem only occurs with Unrealircd 6, but "not" with Unrealircd 5.

and unfortunately I cannot give further information, Unrealircd 6 gives nothing further.


2021-12-22 17:51

administrator   ~0022283

I have set the bug to public again, and made your bug notes 'private' if they contained config or other sensitive information.

Right now I am not working on this bug. I have some deadlines at work (paid work), and while I do work on UnrealIRCd occasionally, I pick up things that are easy to fix there.
This issue is not easily fixable within xx minutes as has "no leads" at the moment and so far you are the only reporting it. If we know the exact cause then that would be more helpful. Again, it's a shame that it isn't producing a minidump or crash backtrace as that would have helped so much.
Maybe someone else will report the same in the next few days and we can see something in common, or maybe that person will have a minidump to go on, or maybe next week I will have more time to reproduce your issue, or someone else will try to do just that. We will see!

For now, don't expect a response from my side in the next few days due to these resource constraints.


2021-12-22 22:21

reporter   ~0022284


Sorry that I can't give you more information that you would like but.

The problem on the server with the Windows Server 2019 operating system is not my server but someone else's.

So the problem already exists twice ...

1x on my computer with Windows 10 Pro
and 1x from someone on the server with Windows Server 2019.

So this is definitely a bug, which was also confirmed on


2021-12-22 23:03

reporter   ~0022285

After I reinstalled my computer today, December 22nd, 2021, I only installed the most important things to access my server and installed mIRC and have now installed Unrealircd 6.

As expected, I can still reproduce the bug


2021-12-26 17:10

reporter   ~0022304

I noticed something else in the Windows version, in the "tmp" folder.

Unrealircd 6 was published on Dec 17, 2021, 6:50 am CET, but how can there be temporary files from 12/16/2021 in the tmp folder?

I think that's the beginning of the bug.


2021-12-28 10:10

administrator   ~0022305

Last edited: 2021-12-28 10:15

I tried the same configuration file as you, on Windows, and unfortunately no crash. To be clear: it means i cannot reproduce the crash with /just/ that, it most likely means there is another factor at play. It could be a certain channel configuration (ban, modes, anything), a certain user online, a certain (far) server with a certain configuration setting, a certain kline, who knows what it is... we simply don't know yet that (extra) factor that triggers the crash.

As for the file dates of the exe and dll's: UnrealIRCd 6.0.0 was already in git ready the day before, and also compiled and signed the day before. So that's unrelated.

In next comment I will give you a debug version. If you can run that and get back to me that would be great.
I will make it a private comment since I don't want to publish the debug version / don't want to give others URL.


2021-12-28 21:51

reporter   ~0022312

Okay, I'll do it then.

I have also temporarily restarted the productive network with version 5.


2022-01-05 11:59

administrator   ~0022352

Any results with the special debug version? Or not tried yet?


2022-01-05 20:49

reporter   ~0022355

You haven't given a URL to the debug version yet.

So I couldn't test it yet.


2022-01-06 09:29

administrator   ~0022357

I heard from k4be that my private bugnotes are not shown to you by the bugtracker software. That's confusing... i did not know that.

With the help of your log file I was able to reproduce the crash immediately on my own machine, so thanks! I will look at fixing the bug later today when I get back home again.


2022-01-06 15:51

administrator   ~0022358

Found the bug. It is in the GeoIP library. On Windows the geoip library does not like IPv6 addresses and (unknown to me) the geoip module did lookups for remote users so it crashed when linking servers and there was a remote IPv6 user. That also explains why it crashed for you all the time and not for me.

As a temporary fix you can download and then put this in C:\Program Files\UnrealIRCd 6\bin
Overwrite the old GeoIP.DLL with this new file. The new file is 341504 bytes. Then (re)start UnrealIRCd 6.

Of course, at a later point we will release a new UnrealIRCd version with this bug fixed. This is just something quick for you.

Thanks for your help!


2022-01-06 15:52

administrator   ~0022359

See previous comment on the fix. And just to add: I recommend to install UnrealIRCd 6.0.1 first and then put the new GeoIP.DLL there. Don't use the special debug version anymore :)


2022-01-10 16:35

reporter   ~0022369

Hello, I've just tested the 6.0.2-rc1 and the IRCd stayed online.


2022-01-10 16:55

administrator   ~0022370

Great, thanks for the confirmation. And thanks for the original report and your patience as well.

In case anyone reads about this bug later: there is no particular git commit this is fixed in as it is not a bug in unrealircd and thus not fixed in unrealircd source. This is fixed in package which is used to compile 6.0.2-rc1+ (and the DLL from that ships with the windows installer of 6.0.2+).

Issue History

Date Modified Username Field Change
2021-12-18 18:33 Manuelchen New Issue
2021-12-18 18:37 syzop View Status public => private
2021-12-18 18:39 syzop Note Added: 0022243
2021-12-18 18:39 syzop Assigned To => syzop
2021-12-18 18:39 syzop Status new => feedback
2021-12-18 18:39 syzop Priority immediate => normal
2021-12-18 18:39 syzop Severity minor => crash
2021-12-18 18:44 Manuelchen Note Added: 0022244
2021-12-18 18:53 syzop Note Added: 0022245
2021-12-18 19:10 Manuelchen Note Added: 0022247
2021-12-18 19:51 Manuelchen Note Added: 0022249
2021-12-18 20:00 Manuelchen Note Added: 0022250
2021-12-19 09:13 syzop Note Added: 0022253
2021-12-19 10:25 Manuelchen Note Added: 0022255
2021-12-19 10:59 Manuelchen Note Added: 0022256
2021-12-20 19:03 Manuelchen Note Added: 0022268
2021-12-22 17:47 syzop Note View State: 0022268: public
2021-12-22 17:51 syzop View Status private => public
2021-12-22 17:51 syzop Note Added: 0022283
2021-12-22 22:21 Manuelchen Note Added: 0022284
2021-12-22 23:03 Manuelchen Note Added: 0022285
2021-12-26 17:10 Manuelchen Note Added: 0022304
2021-12-28 10:10 syzop Note Added: 0022305
2021-12-28 10:14 syzop Note Edited: 0022305
2021-12-28 10:15 syzop Note Edited: 0022305
2021-12-28 12:57 syzop Summary IRCd keeps crashing during a link => Windows: IRCd keeps crashing during a link
2021-12-28 21:51 Manuelchen Note Added: 0022312
2022-01-05 11:59 syzop Note Added: 0022352
2022-01-05 20:49 Manuelchen Note Added: 0022355
2022-01-06 09:29 syzop Status feedback => confirmed
2022-01-06 09:29 syzop Note Added: 0022357
2022-01-06 15:51 syzop Note Added: 0022358
2022-01-06 15:52 syzop Note Added: 0022359
2022-01-10 16:35 Manuelchen Note Added: 0022369
2022-01-10 16:55 syzop Status confirmed => resolved
2022-01-10 16:55 syzop Resolution open => fixed
2022-01-10 16:55 syzop Fixed in Version => 6.0.2-rc1
2022-01-10 16:55 syzop Note Added: 0022370