View Issue Details

IDProjectCategoryView StatusLast Update
0006027unrealircdpublic2021-12-22 17:13
Reporterarmyn Assigned Tosyzop  
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Product Version6.0.0 
Fixed in Version6.0.1 
Summary0006027: Small details spotted in whois and unrealircd.org/json-log
DescriptionHere are 2 small details that are probably poorly organized:

- In the whois, in the raw 344 there is this: "344 Test free31 FR :is connecting from France" - And I find that the "FR" in front of the ":" is not well placed here, or then leave it here but also add it at the end just after "France" so that it gives: "344 Test free31 FR :is connecting from France (FR)" - For questions from args. irc framework from kiwiirc example reads this: "is connecting from France". It is not able to recover the "FR" at the beginning.

- In the "unrealircd.org/json-log" in the spamfilter in "destination", the nickname has a space at the very beginning. It wouldn't bother me for the processing, I would just have to put a trim () when reading but it's still better to warn here in order to avoid putting trim() each time I do javascript

TagsNo tags attached.
3rd party modules

Activities

progval

2021-12-19 11:47

reporter   ~0022260

The first example looks correct to me. The colon is IRC syntax to say that everything after it is the same token, so the whole line should be interpreted as: command "344" with parameters: ["Test", "free31", "FR", "is connecting from France"]

See https://modern.ircdocs.horse/#parameters for details.

armyn

2021-12-19 13:17

reporter   ~0022264

ok @progval I made an update request to "irc framework": https://github.com/kiwiirc/irc-framework/pull/318/commits/e6c761f9b32a66078c9df326736d4221346b8c3f

progval

2021-12-19 14:42

reporter   ~0022265

It shouldn't index parameters from the end, to allow extendability through adding more parameters before the trailing.

armyn

2021-12-20 08:44

reporter   ~0022266

@progval ok I updated: https://github.com/kiwiirc/irc-framework/pull/318/commits/34683a7181aa1d3c384a2cf914149f13019906b8

I had not looked at this log before:
cache.country = JSON.stringify(command.params); // response : Country: ["gentille","armyn","FR","is connecting from France"]

syzop

2021-12-22 17:12

administrator   ~0022280

Last edited: 2021-12-22 17:13

Regarding the 1st issue: as you found out by now: this is intended.

As for the 2nd issue: thanks, I have now removed the extra whitespace:
commit b98d02817aa516b1165f182491e62058502271fe (HEAD -> unreal60_dev)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Wed Dec 22 17:09:35 2021 +0100

    In SPAMFILTER_MATCH log message, remove leading space in 'destination' JSON.
    Reported by armyn in https://bugs.unrealircd.org/view.php?id=6027

Issue History

Date Modified Username Field Change
2021-12-19 10:51 armyn New Issue
2021-12-19 11:47 progval Note Added: 0022260
2021-12-19 13:17 armyn Note Added: 0022264
2021-12-19 14:42 progval Note Added: 0022265
2021-12-20 08:44 armyn Note Added: 0022266
2021-12-22 17:12 syzop Assigned To => syzop
2021-12-22 17:12 syzop Status new => resolved
2021-12-22 17:12 syzop Resolution open => fixed
2021-12-22 17:12 syzop Fixed in Version => 6.0.1
2021-12-22 17:12 syzop Note Added: 0022280
2021-12-22 17:13 syzop Note Edited: 0022280
2021-12-22 17:13 syzop Note Edited: 0022280