View Issue Details

IDProjectCategoryView StatusLast Update
0006041unrealircdpublic2022-05-07 18:54
ReporterValware Assigned Tosyzop  
PrioritynoneSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version6.0.0 
Fixed in Version6.0.4-rc1 
Summary0006041: Please add command SVSO
DescriptionI think it would be a great addition to the SVSCMDS and majorly assist in integration/delegation :D
please can we have params "<user> <opertype>"

many thanks!
TagsNo tags attached.
3rd party modules

Activities

syzop

2022-05-07 18:54

administrator   ~0022471

Done in https://github.com/unrealircd/unrealircd/commit/50e5d91c798e7d07ca0c68d9fca302a6b6610786
Obviously needs more testing :). And docs need to be updated.

commit 50e5d91c798e7d07ca0c68d9fca302a6b6610786 (HEAD -> unreal60_dev, origin/unreal60_dev, origin/HEAD)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Sat May 7 18:48:19 2022 +0200

    Add SVSO command which services can use to make someone IRCOp.
    This existed in UnrealIRCd 3.2.x but was later removed when
    switching to the new operclass system.
    Requested by Valware in https://bugs.unrealircd.org/view.php?id=6041
    
    Syntax: SVSO <uid|nick> <oper account> <operclass> <class> <modes> <snomask> <vhost>
    All these parameters need to be set, you cannot leave any of them out,
    HOWEVER some can be set to "-" to skip setting them, this is true for:
    <class>, <modes>, <snomask>, <vhost>
    
    In UnrealIRCd the <operclass> will be prefixed by "services:" if not already
    present. It is up to you to include or omit it.
    
    If you want to set any swhoises you need to use the SWHOIS s2s command,
    other than that this command basically does everything for you,
    in fact it uses the same code as the OPER command does.
    Most of the "user is now ircop" code has been moved out of cmd_oper() to
    a new function make_oper() that is called by both cmd_oper() and cmd_svso().
    
    This function also changes the hook HOOKTYPE_LOCAL_OPER:
    It no longer passes a ConfigItem_oper struct, since we can't do that for
    remote opers. Instead it passes oper name and oper class.
    The complete definition is now:
    int hooktype_local_oper(Client *client, int add, const char *oper_block, const char *operclass);

Issue History

Date Modified Username Field Change
2021-12-28 18:14 Valware New Issue
2022-05-07 18:54 syzop Assigned To => syzop
2022-05-07 18:54 syzop Status new => resolved
2022-05-07 18:54 syzop Resolution open => fixed
2022-05-07 18:54 syzop Fixed in Version => 6.0.4-rc1
2022-05-07 18:54 syzop Note Added: 0022471