View Issue Details

IDProjectCategoryView StatusLast Update
0006055unrealircdpublic2022-05-25 17:01
Reporterdjsxx1984 Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version6.0.1 
Summary0006055: color get striped after setting ~text:censor:*word*
DescriptionWhen adding a text ban with censor, all the color is striped when the censored word comes in the sentence
See below screenshot
Steps To Reproduce[10-01-2022][21:42:54] <Chat4UsPlayer> Nu te horen op Chat4Us: AutoDJ: Danny de Munk - Mijn Zoon
[10-01-2022][21:45:42] * Stanley sets mode: +b ~text:censor:*Chat4Us*
[10-01-2022][21:46:27] <Chat4UsPlayer> Nu te horen op <censored>: AutoDJ: Arie Ribbens - Polonaise Hollandaise <-- striped
TagsNo tags attached.
3rd party modules

Activities

djsxx1984

2022-01-10 21:50

reporter  

afbeelding.png (8,867 bytes)

syzop

2022-05-25 17:01

administrator   ~0022519

I'm afraid that is by design. It strips all the color and other control codes first, and then does the replacement. The reason for it is that otherwise people can evade the filtering too easily by sending things like "fu" + color 3 + color + "ck" etc.

Issue History

Date Modified Username Field Change
2022-01-10 21:50 djsxx1984 New Issue
2022-01-10 21:50 djsxx1984 File Added: afbeelding.png
2022-05-25 17:01 syzop Assigned To => syzop
2022-05-25 17:01 syzop Status new => closed
2022-05-25 17:01 syzop Resolution open => no change required
2022-05-25 17:01 syzop Note Added: 0022519